Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am and end user end user of Novell Netware. Whenever I restart my computer and login via Novell, my drives do not mount until I re-authenticate to the network using LDAP. Is there a way to keep these shared drives mounted?

share|improve this question

migrated from serverfault.com Jul 18 '11 at 15:05

This question came from our site for professional system and network administrators.

    
I have not used NetWare in years, and never with anything newer than Windows 98, so I don't know if this will work. Try browsing to your NetWare server through "Network", and then right-click on the resource and click "Map Network Drive", and check the box "Reconnect at Logon". Then I would also enable off-line files for any personal drive mappings you may have. –  KCotreau Jul 18 '11 at 15:11
add comment

3 Answers

up vote 2 down vote accepted

This can be done the same way you make Windows drive-mapping sticky. You'll need to already be logged into the Netware network for it to work, though. Make sure to check the "Reconnect at logon" box when setting up the drive-mapping.

If you're running the Novell client, it is possible to make your own login-script to map these drives. This will work even if you don't log into the Netware network when you log in to your user session for the first time.

share|improve this answer
    
I posted mine as a comment because I am not sure you can do it like this, because Windows uses pass-through authentication when you log in, so you are being authenticated based on that. When you log into Windows, in this case, you still have no rights to the drive. –  KCotreau Jul 18 '11 at 15:22
    
@KContreau IF the Netware client is installed and logged in, mapping to a Netware server will cause Windows to pass the Novell credential. If it is installed, but not logged in, it'll trigger a login prompt. Things get murkier when CIFS is the connection method, not NCP. –  SysAdmin1138 Jul 18 '11 at 15:25
    
I forgot that tab was there, that might be the real answer: To make sure that tab is passing the credentials along. By the way, there is no "N" in my name please. –  KCotreau Jul 18 '11 at 15:27
add comment

there is option (in almost cases, I can't see that locked) mapping network disk/area(s) by using user script (depends of setting would be saved and authentificated against accesses saved in LDAP too) very simple by right-clicking on Novell icon in the system try, and I'm talking about Windows OS

share|improve this answer
add comment

I wonder if you turned off the option to run login scripts? Or perhaps your first login is not running them? If you have access to the Client32 Settings control panel (via Control panels, or via the red N in your SysTray).

Take a quick look at the System Login Profiles tab, then click on the profiles listed. Usually just have the Default, and Properties of it.

Look at the Script tab in the window that pops up. You want Enable tab on, and Run scripts on.

Then on your next login, check the Scripts tab and see if Run Scripts is ticked at startup.

Also, you should tick the Save profile after successful login at the top of the window.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.