Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This is for a Windows XP SP3 machine, trying to access file shares on a Windows Server 2008 R2 system.

The client had access to the server previously, and other clients on the same network are not having problems. Other network functions for the troubled client do not seem to be affected.

When trying to access a file share via \\servername\sharename\ or \\IPAddress\sharename\ the following error is returned: "The network path was not found". This also happens when trying to access the server by running \\servername\ or \\IPAddress\. However, the server pings fine by name and IP from the same machine.

Windows Firewall is off, and the user does have appropriate permissions. The IP configuration, including address, subnet mask, gateway, and DNS server, are correct. The system has been rebooted several times during troubleshooting.

What am I missing?

share|improve this question
    
Is "File and printer sharing for Microsoft Networks" installed under the network adapter? what an odd problem.... btw –  Kyle Jul 18 '11 at 19:09
    
@Kyle - I'll make sure to check that, the next time I look at the problem. But, I'm pretty sure it is. –  Iszi Jul 18 '11 at 19:10
    
Yea it is by default, but it looks like you already checked everything else that can get in the way... You might want to check if it can connect to any other shares just to help narrow down the scope of the issue... –  Kyle Jul 18 '11 at 19:12
    
@Kyle - The server it's connecting to is the only one with shares on the network. And, if it can't connect to \\servername\ or \\IPAddress\, it's not going to be able to get any further in the file share structure. –  Iszi Jul 18 '11 at 19:14
    
Just share out a folder from another xp machine.... should take about 60 seconds (maybe more if you have to turn the firewall off or walk someone else through it) –  Kyle Jul 18 '11 at 19:17
show 2 more comments

3 Answers 3

Are you using Active Directory? I have had a similar issue with a user today - she could get to the share via Citrix but not the ip or sharename. After a lot of investigations by various departments I created a new AD account and she is accessing the shares fine, although I'd been told it wasn't an AD problem!

share|improve this answer
add comment

I Found Out that on win 2008 - there was two IPs on the one Network Card (192.168.3.1, 192.168.1.1).: Problem is that 139 port was open only onto last one, but is was supposed to be opened onto both.

Netstat returned me: 192.168.1.1:139 but there was no 192.168.3.1:139)

win2003 and 2008 handle it well, when connecting to such share, but XP fails when trying \192.168.3.1\

I could connect my XP only when removed second IP from server 2008.

Oleg.

share|improve this answer
add comment
up vote 4 down vote accepted

Though there may be other possible causes for this issue, this particular case was due to Client for Microsoft Networks being un-installed. Also of note is that the Computer Browser service was not registered.

Troubleshooting Steps:

  1. Run services.msc and look for the "Computer Browser" service. This should be somewhere between the "COM+" services, and "Cryptographic Service".

    • If the "Computer Browser" service is not present, you probably need to re-install Client for Microsoft Networks. Proceed to step 2. If the service is present, follow the rest of the bullets in this step, and skip the remaining steps.

    • If the "Computer Browser" service's Startup Type is Disabled or Manual, open the Properties page and change it to Automatic.

    • If the "Computer Browser" service is stopped, start it.

  2. Open the Properties page of your network connection. In the list that says "This connection uses the following items:" check for "Client for Microsoft Networks".

    • If "Client for Microsoft Networks" is present, verify the "Computer Browser" service's settings, per the last two bullets of step 1. If those settings are correct, and a reboot does not solve the problem, there's a different issue at hand.

    • If "Client for Microsoft Networks" is not present, proceed to step 3.

  3. Reinstall "Client for Microsoft Networks".

    • In the Properties page of your network connection, below the list marked "This connection uses the following items:", click "Install...".

    • In the "Select Network Component Type" dialog, select "Client", then click "Add...".

    • In the "Select Network Client" dialog, select "Client for Microsoft Networks", then click "OK.

    • In the Connection Properties dialog, click OK.

  4. Reboot the computer.

share|improve this answer
    
+1 I was thinking we should write write something up last night so it was available for future reference... I see you beat me too it. –  Kyle Jul 19 '11 at 13:47
    
Thanks again for the help, @Kyle! –  Iszi Jul 19 '11 at 13:51
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.