Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Running Debian/Crunchbang and I'm getting a strange error when I'm trying to run scripts. For example

exec: 392: ./firefox-bin: not found

I have never encountered this before and I could not find any good information on this, Is there anyone who care to explain what it means and why it occurs?

The file that is apparently "not found" do exist at that path and are owned by me and executable. I have also tried to execute it from different locations but without luck.

share|improve this question
    
Script sample?? –  Linker3000 Jul 18 '11 at 19:52

3 Answers 3

If you're sure that the file in question exists then what it probably means is that the 'interpreter' for the file is not found. As firefox-bin should be an ELF executable file the interpreter for it will likely be something like /lib/ld-linux.so.2 and it is that file that is probably missing.

Try running readelf -l ./firefox-bin to find out what the interpreter is - look for the "[Requesting program interpreter: /lib/ld-linux.so.2]" line in the output.

share|improve this answer

As TomH said, this is likely because the firefox-bin file has the wrong binary format (the "not found" message is misleading). You probably downloaded the 32-bit version of Firefox (the Firefox download page only offers 32-bit), and tried to run it on a 64-bit system that does not have backwards-compatible libraries. If that is the case, there are two solutions:

share|improve this answer

From your sample, it looks as if the script says "./firefox-bin". that is, it wants the firefox executable to be in the same directory as the script, which is not assured. What if you replace that with the full path to the file?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.