Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

In Excel 2007, I see that the content of some cells are displayed as hash characters (###). These cells are formatted as text and their contents are displayed like this if the number of characters are more than 255.

Is there any way to fix this?

share|improve this question
up vote 9 down vote accepted

Cells formatted as text can only handle 256 characters. Anything more and they will be displayed with hash characters (###).

To get around this limitation, you can change the formatting of the cell to General. This format has a much larger character limit.

share|improve this answer

This is excels way of telling you that the field does not fit in the cell.

If you make the cell-width "automatic," the hashes will dissappear.

This generally happens when you give a cell a specific format and Excel feels it doesn't fit in view.

EDIT: To make your cells auto-width:

Double-click on the right edge of the column header. That is, at the top, you have columns A,B,C... Say you want to expand the values in column E. You have to double-click on the edge between columns E and F.

This will expand the cell size. Also, if you have text in the cell, you can always right-click on the cell, click on Format Cells, and then put a check next to Wrap-text.

share|improve this answer
How do I make the cell width automatic? – Ashwin Nanjappa Jul 19 '11 at 12:08
Akseli: Thanks, but I found a better solution that works for longer text. – Ashwin Nanjappa Jul 20 '11 at 6:32

Try this. While opening the Excel file, select the text option. Here, one important thing is how you are writing the content to the Excel file. If you do it manually then do not write something which Excel does not allow. But if you want to write in your code then use POI/JExcel.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .