Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Possible Duplicate:
How to enable 4GB in my Windows 7 64 bit?

I have a computer that I have upgraded to Windows 7 Professional 64bit. It has an intel D945GB1 motherboard, Pentium D Dual core processor, nVidia Quadro FX 580 video card, 4 sticks of DDR2 1 GB memory. In the BIOS, I see all 4 sticks of memory. The Resource Monitor shows 1027 MB "Hardware Reserved".

I would try to get with intel about the motherboard, but it was made for Gateway's Business division which is no longer around, so I have no resources to tap into there. I cannot find if there was an update to the BIOS to fix the problem. The computer was originally sold to me as an XP Pro machine (32 bit) with 2 GB memory. The Upgrade Advisor indicated no problems like this.

When I remove the video card and run on the onboard video, the Hardware Reserved goes down to 780 MB or so. When I disable the onboard video, it goes back to 1027. In the memory table in device manager, I see from C0000000 to F0000000 (about 805 meg) used by PCI Bus in one block, but cannot find what on the bus is doing with this. I cannot find memory remapping in the bios, the max memory in msconfig is UNchecked, I have upgraded what drivers I can find, I have tried everything I an think of.

Any ideas?

share|improve this question
3  
I know this is going to sound off - but are you sure you've installed the 64 bit version of Windows 7? Go to Control Panel\System and Security\System and see what it says. –  ChrisF Jul 19 '11 at 20:57
1  
Yes it is 64 bit. I have seen things like that before, so no problem. –  Bill Jul 19 '11 at 21:00
add comment

marked as duplicate by Linker3000, Sathya Jul 20 '11 at 5:11

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

2 Answers

The Intel 945 chipset only supports 32 bit memory address (yes even though it supports 64 bit CPU's). It's the same effect as having a 32 bit OS, but this limit is imposed in hardware so there is no solution other than getting a new motherboard.

See How to enable 4GB in my Windows 7 64 bit?

share|improve this answer
1  
AHA!!!!!!!!!! I knew that there would be a SOLID reason for this. I have the same problem with TWO computers. Thanks!!!! –  Bill Jul 19 '11 at 21:31
add comment

If you're sure you have 64-bit Windows 7, your issue is probably that the frontside bus chip is 32-bit only, so it won't let even a 64-bit OS on a 64-bit processor use all 4 gigs of RAM properly.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.