Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have tried three different drives in the USB enclosure, plugged into my Windows 7 machine, and it doesn't work.

When the driver is being installed, it fails and says that it cannot find the driver.

I even go to command prompt, running as Admin, and do diskpart, and from there do list disk and still don't see the disk included in that list.

Also, when I go into Computer Management and go to Disk Management under Storage, I don't see the disk listed.

I am running Windows 7 Professional, SP1, with the latest updates and not sure what's happening.

The USB enclosure I am using is Macally Model: G-S350SUA

Anyone have any thoughts?

share|improve this question
up vote 1 down vote accepted

There are no special drivers for that model on the manufacturer's web site so unless you can test it with another computer, even XP, there is probably not much more you can do. You surely have a friend, who would let you plug it into his computer?

My gut tells me that is it broken, and that you should call or e-mail the manufacturer (they may have some miracle information that might make it work), and if it is still under warranty, you should go that route.

share|improve this answer
It seems your gut is right. I tried another enclosure and it works - so it seems your gut was right and this damn thing is broken. – marcamillion Jul 21 '11 at 0:20

The USB enclosure (the electronics) OR the USB cable might be broken.

I would suggest connecting it to another computer, just to make sure that it's not a problem with your computer and/or Windows installation. As you have tested different drives, you know that the problem is not caused by them.

You can:

  1. Try another USB cable.
  2. Try another enclosure.
  3. Try the enclosure on another computer.
share|improve this answer
I hear the windows sound when I plug it in, but it's not finishing the install....could that still be the cable? I don't have another enclosure unfortunately :( Also don't have another windows 7 machine. – marcamillion Jul 20 '11 at 7:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .