Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This is what I see when I view a website using Helvetica Neue in Chrome 12.

enter image description here

I'm running Windows 7 Professional 32-bit, and IE9 and FF5 both render the text differently readable (using the next font in the CSS stack).

I've checked my Fonts folder (C:\Windows\Fonts) and I can't see any version of Helvetica anywhere.

Does anyone have any ideas?

share|improve this question
1  
It seems the problem is not preventing Helvetica Neue (because it isn't installed, anyway) but making IE9 and FF5 use the same font instead. Doesn't the font stack apply to both? –  pavium Jul 20 '11 at 10:13
    
@pavium, except that if IE9 and FF5 did what Chrome does then I wouldn't be able to read sites using Helvetica in any browser. –  Jon Jul 20 '11 at 12:35
    
@Jon Helvetica looks unreadable anyway even if displayed correctly. It is a display typeface, not designed for running text. –  kinokijuf May 25 '13 at 13:17

2 Answers 2

up vote 1 down vote accepted

It turns out that Helvetica was installed, but Windows wasn't showing it in the Fonts folder.

I used FontExpert to track it down and remove it and that seems to have fixed things.

share|improve this answer
    
Jon, how did you get this to stick? I've used FontExpert to remove HelveticaNeue (not Helvetica itself), but TweetDeck is still showing up with the same garbage characters you had. Should I remove Helvetica, as well? Any other thoughts? –  JoshSamBob Aug 16 '12 at 16:33
    
@JoshSamBob not sure I'm afraid, might be worth a shot! –  Jon May 29 '13 at 14:25

I can't see your screenshot.

Chrome should use another font, which is set in the CSS, or which is set in the browser settings. The CSS should work for all browsers the same, although a (not so?) clever css-developer might want to use alternate css for different browsers.

In Chrome, click on the wrench-icon right next to the address bar, choose preferences, then choose "under the hood", web content > customize fonts. There you can set which font you want to see as standard serif/sans-serif or mono font.

share|improve this answer
    
I reupped the screenshot, you should be able to see it. –  slhck Jul 20 '11 at 11:02
    
@slhck Thanks for updating the screenshot. I understand that Chrome should use another font - what I don't understand is why it isnt doing that. The customized font settings are Times New Roman and Arial (which Chrome has no problem rendering). My encoding is set to Western ISO-8859-1 if that makes any difference... –  Jon Jul 20 '11 at 12:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.