Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Why would an external eSata Drive (xSonic with 500Gb notebook Hard Drive) run ok on a Silicon Image based PCI-E to eSata adaptor at about 35MB/s, But then run really slow when plugged into NForce4 Sata socket via cable?

I have another version of the problem with Really slow 1MB/s!!! performance on a ASUS P5K Pro Motherboard with E8400 CPU. This time the same card is plugged into a PCI-E socket. The same eSata drive is plugged into the Esata port on the card.

All this is running on Windows XP Pro 32bit.

Any suggestions on how to diagnose the problems??

share|improve this question
    
Have you tried using a different eSATA cable? Perhaps the one you are using is bad. –  firedfly Aug 29 '09 at 2:18
    
eSATA is notorious for bad / buggy implementation in hardware and BIOS support. I'm not surprised by your experience and can share similar. –  user12889 Apr 19 '10 at 5:40
    
is your motherboard SATA controller in AHCI mode or IDE mode? –  quack quixote Jun 15 '10 at 17:06

2 Answers 2

Have you tried using on of the S.M.A.R.T. HD tools? I would use one of these tools to see if there is a difference in read/write errors.

Some programs that read the S.M.A.R.T. information from the hard drive are:

share|improve this answer
    
I'll try that. Thanks. –  Jon Aug 28 '09 at 22:06

My first guess would be that it is a problem with the plugs. I use an Asus P5Q-E and an external ICY-Dock and I always have trouble with the plugs.

I runs for month without error, but when I fiddle with the cabling at the back of my box (e.g. plug in some USB device or something) I get lots of read errors (ubuntu: tail -f /var/log/messages, don't know how to check this in XP). It's like the slightest breeze can cause the plugs to loose proper contact.

I boot from the eSATA drive. Sometimes I plugged in or out some device (USB, keyboard, anything) when the computer was off and when I turned it on it got stuck somewhere in the boot process. Took me a while until I found out what the reason was.

My second guess: hanleyp mentioned here that the (e)SATA specs have changed in mid-2004 to allow for larger cable lengths. Maybe your PCI-E operates according the new spec and the signals are strong enough for your setup (cable length, interference). Maybe the motherboard operates according to the old spec and the signals are just a little too weak.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.