Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

How can we VNC to Mac OS X Lion to use screen sharing? RealVNC for Windows connects and shows a lock screen, but I cannot click or type a password. What clients will work now?

share|improve this question
Did the approach you're using work on Snow Leopard? – Doc Jul 20 '11 at 15:23
Yes, it worked with Snow Leopard. I started the installation of Mac OS X Lion remotely using RealVNC. After restarting, I had this problem. – user16659 Jul 20 '11 at 15:38
Somehow it just worked now. I connected and kept clicking in the password field and the text cursor started blinking, but then it froze. I reconnected and clicked inside the field and was able to enter the user password and log in. – user16659 Jul 20 '11 at 16:09
I still can't connect to Lion using my IPad. Worked on Snow Leopard. – Mark Richman Jul 24 '11 at 14:18

(Solved) How to fix VNC ARD screen sharing in Lion says restart services or downgrade ARD.

share|improve this answer

I have narrowed this down to the screen going to sleep (and of course, the computer going to sleep.)

If you just enable the screen saver and disable both the screen and computer sleep it works. I posted this on Apple's forum but they haven't done a thing about it.

I even tried installing TeamViewer but I get same results. I can wake up my mac mini when I access it with TeamViewer but screen stays asleep, even if I have screen sleep disabled...go figure. What I did at work was leave my mac mini awake (both screen and cpu) and just enabled the screen saver.

share|improve this answer

I experience the same behavior using Chicken of the VNC and connecting to a Lion computer. Sometimes the login freezes and I can't type. Usually quitting CotVNC and trying again clears it up. Quite frustrating. I've had the same behavior with JollysFastVNC.

share|improve this answer
I found if I kill some processes VNC will work again. I'm unsure which ones: screensharingd, SecurityAgent, ???. – user16659 Aug 8 '11 at 14:10
VNC to a local host had stopped working (connection just never completed). SSHing in and killing screensharingd brought it back to life instantly. – Perry Feb 3 '13 at 6:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .