Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently uninstalled ZoneAlarm and have decided to use Windows Firewall as my firewall as ZoneAlarm was causing me grief when I was syncing my iphone.

Anyway, I've noticed just then that Windows Firewall seems to block my Windows updates.

Whenever I have the firewall on, I get a 8024402C error when I try to update, and it seems to update fine when I don't have the firewall on.

there is a help page for this error http://answers.microsoft.com/en-us/windows/forum/windows_other-windows_update/8024402c-error/760ba53f-2cb1-48be-a77f-61bf445fddde

but it seems to assume that the firewall I have is third party, I'm not sure how to fix it if Windows Firewall itself is the firewall that is blocking the automatic updates.

share|improve this question
    
sorry Windows 7 –  RoboShop Jul 20 '11 at 16:17
    
Actually, I should have noticed the tag...My fault, just missed it. –  KCotreau Jul 20 '11 at 16:30
    
nah actually i added in the tag after u noted me on it –  RoboShop Jul 21 '11 at 1:26
add comment

5 Answers 5

Go to Control Panel>Firewall>Advanced Settings. Then click Action>Export policy to make a copy of your current policy in case you want to restore it. Then click Action>Restore Default Policy.

If it really is just the Firewall, this should allow you to use Windows Update.

enter image description here

share|improve this answer
    
I have tried to restore to default, however, the same problem still exists. Is this then not a firewall issue? I don't understand how than stopping the firewall will cause it to work. –  RoboShop Jul 21 '11 at 1:27
add comment
up vote 2 down vote accepted

I've found solution.

I found it here.

Essentially I added a new incoming rule which allowed all connections coming from c:\windows\System32\svchost.exe.

I wonder why my default settings didn't already have this? Anyway it worked!

share|improve this answer
    
When adding this rule on Windows 8, Windows Firewall warns me that this rule would not work as expected. Do you know what could it mean? –  utapyngo Aug 5 '13 at 9:12
add comment

Open Command Prompt as administrator and type the following commands, one by one (press ENTER after each command):

 - netsh winhttp reset proxy 
 - net stop wuauserv 
 - net start wuauserv

Try to install the updates again.

Source: http://support.microsoft.com/kb/900936

share|improve this answer
1  
He already said Windows Update works if he turns off the firewall ("it seems to update fine when I don't have the firewall on"), so no need to reset any of this. –  KCotreau Jul 20 '11 at 16:41
    
You're right... –  Nicu Zecheru Jul 20 '11 at 17:36
add comment

Here is how to change firewall settings in Windows 7, you can watch the video to learn the steps ;

Allow a program to communicate through Windows Firewall

By default, most programs are blocked by Windows Firewall to help make your computer more secure. To work properly, some programs might require you to allow them to communicate through the firewall.

Watch this video to learn how to allow a program to communicate through Windows Firewall (1:12)

Open Windows Firewall by clicking the Start button Picture of the Start button, and then clicking Control Panel. In the search box, type firewall, and then click Windows Firewall.

enter image description here

In the left pane, click Allow a program or feature through Windows Firewall.

Click Change settings. Administrator permission required If you're prompted for an administrator password or confirmation, type the password or provide confirmation.

Select the check box next to the program you want to allow, select the network locations you want to allow communication on, and then click OK.

Warning Before allowing a program through the firewall, make sure you understand the risks involved. For more information, see What are the risks of allowing programs through a firewall?

http://windows.microsoft.com/en-US/windows7/Allow-a-program-to-communicate-through-Windows-Firewall

share|improve this answer
1  
The key is "what program?", or what ports? It is not listed there. It must come under the umbrella of some more esoteric listing. –  KCotreau Jul 20 '11 at 16:40
    
@KCotreau : yeah there is no like "Windows Update" program on there for me to choose. –  RoboShop Jul 21 '11 at 1:30
add comment

In Win 8 Go to Control Panel>Firewall>Advanced Settings. Then click Action>Export policy to make a copy of your current policy in case you want to restore it. Then click Action>New Rule>Custom>Next in the Program step of New Outbound Rule Wizard under the Service heading select Customize>Apply to this service>Windows Update>OK

Optional: Program: select "this program path" and select the program c:\windows\System32\svchost.exe press ok

Optional: Protocol and Ports: specify tcp port 443

Allow this connection; select your profile or leave as is (it should be explained in the wizard pretty well); give it a name; finish

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.