Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently built a new PC and it works perfectly. However, my internal SATA 6 hard drive is being recognized as an external USB hard drive by Windows 7. The hard drive works fine, but it's annoying seeing the USB icon in the taskbar when I don't actually have any USB components connected...

Can anyone give me insight into what's wrong with my system, and how to fix it?

share|improve this question
    
One possible reason for this could be the interface used to connect your hard disk; the PC's manufacturer could be using one e-sata interface to connect your disk to your mainboard. –  Diogo Jul 20 '11 at 19:25
    
I don't have access to my desktop right now, but I'll look into my motherboard manual and confirm this suspicion, and report back! Thanks. –  confusedKid Jul 20 '11 at 19:30
    
Right, please confirm it, if it is really true i will change the comment for an ansewar. Thanks –  Diogo Jul 20 '11 at 19:39
    
It could be that the motherboard supports SATA hotplugging for regular SATA ports. In that case the described behavior is normal. –  AndrejaKo Jul 20 '11 at 20:51
    
Also check in the device manager if the HDD is actually being detected as USB or SATA. The "USB icon" does not imply that the device is actually an USB device. –  AndrejaKo Jul 20 '11 at 20:58

1 Answer 1

up vote 2 down vote accepted

Your drive isn't being detected as a "USB drive", it's a device with hot plugging enabled (which USB devices also are). You can disconnect the hard drive by Safely Removing it and unplugging it while the computer is on.

My mainboard lets me turn this on and off for individual SATA ports. Some have a master switch for the whole SATA controller, and yet others don't let you toggle it at all. In this last case you can sometimes switch your SATA controller drivers to disable the feature, but it's not actually harming anything to have it on. Windows won't let you unmount your system drive because there are too many important files open and locked on it.

share|improve this answer
    
Yes, you're right. I haven't updated this post in a long time because I thought no one was reading it. I should've at least posted how I got rid of the icon (turning off the option for hot plugging in my BIOS). –  confusedKid Dec 9 '11 at 17:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.