Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

After upgrading to Lion, I'm unable to add my home folder to the favorites section of my Finder's sidebar. I tried it through Finder Preferences by ticking the checkbox, but it deactivates itself after I click it. I've also tried dragging the home folder into the sidebar, but that doesn't do anything either (no error message) :(

share|improve this question
    
Can you add any other folders into the sidebar? –  Vervious Jul 21 '11 at 4:10
    
Yep, everything else works fine –  x3ro Jul 21 '11 at 4:11
    
Does deleting ~/Library/Preferences/com.apple.sidebarlists.plist and com.apple.sidebarlists.plist.lockfile and restarting Finder do anything? –  Vervious Jul 21 '11 at 4:17
    
Unfortunately not –  x3ro Jul 21 '11 at 5:42
    
Apparently Apple has fixed the problem mentioned in the question. In Lion OS X version 10.7.3, I find that you can click the checkbox for your home folder in Finder Preferences -> Sidebar (which is unchecked by default), and it will stay checked, after which it shows your home folder in the sidebar. –  user147203 Jul 19 '12 at 21:54

3 Answers 3

up vote 6 down vote accepted

I had the same problem, turning off legacy FileVault, as Andrey suggested, solved the problem for me.

Legacy FileVault encrypts the user's home directory only, whereas FileVault in Lion encrypts the entire disk. I'm almost sure, adding the home folder to the sidebar will work with Lion's standard FileVault activated.

share|improve this answer
    
Just wanted to chime in that this matches my experience as well. –  Alan H. Aug 3 '11 at 5:10

I had the same issue until I turned off FileVault on my home folder. And now I can add my home folder to the sidebar in Finder.

share|improve this answer

I had trouble finding my home folder in Finder. An easy way to find it if you have the same problem is to open up Termainal and type "open ~" (the ~ means your home directory).

share|improve this answer

protected by Community Jul 20 '12 at 2:54

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.