Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Dual monitor setups on GNU/Linux are known to be great fun! After fiddling with my xorg.conf for a couple of days, I've managed to come to a point where I can get pretty much what I want (two screens next to each other, windows draggable from one screen to the other) by starting up X, and then manually calling:

xrandr --output CRT2 --right-of DFP2

I'm using RandR 1.3 because Xinerama does not work for my setup (and seems to be obsolete in a way, too).

According to this website, I should be able to achieve the same effect statically through my xorg.conf - however, I don't seem to get it working correctly.

I'm using the fglrx driver for my ATI card, GNOME 2.32.1, and here is my xorg.conf:

Section "ServerFlags"
    Option      "RandR" "on"
EndSection

Section "Device"
    Identifier  "Device"
    Driver      "fglrx"
    BusID       "PCI:1:0:0"
    Option      "Monitor-DFP2"      "Monitor0"
    Option      "Monitor-CRT2"      "Monitor1"
EndSection

Section "Monitor"
    Identifier      "Monitor0"
EndSection

Section "Monitor"
    Identifier      "Monitor1"
    Option          "RightOf"       "Monitor0"
EndSection

Section "Screen"
    Identifier      "Screen"
    Device          "Device"
    Monitor         "Monitor0"
    DefaultDepth     24
    SubSection "Display"
        Depth     24
        Modes     "1920x1080"
        Virtual   3840 1080
    EndSubSection
EndSection

To me, this looks pretty much like the setup recommended on the aforementioned website, however, I will simply get the same image in both monitors. Again, I can call xrandr afterwards to achieve the desired effect.

Any ideas how I can fix my xorg.conf?

share|improve this question

3 Answers 3

You forgot a "Monitor" entry in the Screen section.

See below:

Section "Device"
        Identifier     "nvidia"
        Driver "nouveau"
        Option "Monitor-DVI-D-0" "samsung"
        Option "Monitor-VGA-1" "acer"
EndSection


Section "Monitor"
          Identifier   "samsung"
        Option "PreferredMode" "1280x1024_60.00"
EndSection


Section "Monitor"
          Identifier   "acer"
        Option "PreferredMode" "1280x1024_60.00"
          Option "RightOf" "samsung"
EndSection

Section "Screen"
    Identifier "screen1"
   Monitor "samsung"
    DefaultDepth 24
      SubSection "Display"
       Depth      24
       Virtual 2560 2048
      EndSubSection
    Device "nvidia"
EndSection

Section "ServerLayout"
    Identifier "layout1"
    Screen "screen1"
EndSection
share|improve this answer

I have Fedora 14 with dual monitors specified in xorg.conf, using the ATI proprietary fglrx driver, with the desktop spread across both monitors.

I believe I used aticonfig --initial=dual-head to generate my xorg.conf a year or so ago and tweaked it a bit. Try that. For reference, here is my xorg.conf.

Section "ServerLayout"
    Identifier     "aticonfig Layout"
    Screen      0  "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Files"
EndSection

Section "Module"
EndSection

Section "Monitor"
    Identifier   "aticonfig-Monitor[0]-0"
    Option      "VendorName" "ATI Proprietary Driver"
    Option      "ModelName" "Generic Autodetecting Monitor"
    Option      "DPMS" "true"
EndSection

Section "Monitor"
    Identifier   "0-DFP3"
    Option      "VendorName" "ATI Proprietary Driver"
    Option      "ModelName" "Generic Autodetecting Monitor"
    Option      "DPMS" "true"
    Option      "PreferredMode" "1920x1200"
    Option      "TargetRefresh" "60"
    Option      "Position" "0 0"
    Option      "Rotate" "normal"
    Option      "Disable" "false"
EndSection

Section "Monitor"
    Identifier   "0-DFP4"
    Option      "VendorName" "ATI Proprietary Driver"
    Option      "ModelName" "Generic Autodetecting Monitor"
    Option      "DPMS" "true"
    Option      "PreferredMode" "1280x1024"
    Option      "TargetRefresh" "60"
    Option      "Position" "1920 176"
    Option      "Rotate" "normal"
    Option      "Disable" "false"
EndSection

Section "Device"
    Identifier  "aticonfig-Device[0]-0"
    Driver      "fglrx"
    Option      "Monitor-DFP3" "0-DFP3"
    Option      "Monitor-DFP4" "0-DFP4"
    BusID       "PCI:2:0:0"
EndSection

Section "Screen"
    Identifier "aticonfig-Screen[0]-0"
    Device     "aticonfig-Device[0]-0"
    Monitor    "aticonfig-Monitor[0]-0"
    DefaultDepth     24
    SubSection "Display"
        Viewport   0 0
        Virtual   3200 3200
        Depth     24
    EndSubSection
EndSection
share|improve this answer
    
Thanks, but that didn't work for me. aticonfig generates a xorg.conf that basically displays clones of a single Desktop. –  Thomas Jul 25 '11 at 1:28

My end goal was the same as yours:

I want two screens next to each other, windows draggable from one screen to the other

Here is how I did it on Kubuntu 12.04 with the ATI proprietary drivers (same as you are using). These first two steps were critical for me. (Without them, I had all kinds of problems with my dual monitor setup.)

sudo apt-get --purge remove fglrx*
sudo apt-get install fglrx-updates fglrx-amdcccle-updates

Set up monitors by running the GUI tool from a root shell:

$ sudo -s
# amdcccle

Uncheck the "clone" option. That was enough in my case. Note that I cannot get that GUI utility to work unless I start it as above.

---Quote--- Today's X rarely requires manual configuration. X now automatically configures itself with reasonable defaults. Both GNOME and KDE provide GUI utilities for customizing settings beyond these defaults if you like.

However, sometimes you need to muck with the configuration manually, beyond what these tools allow... ---End Quote---

The above was true for me. From your question, I don't see why it would not be true for you too. I did not have to tweak Xorg.conf or xrandr. However, when I moved to 3 monitors, I had to tweak a couple things in the config files, but I never had a problem with the monitors reverting to "clones" after I unchecked the "clone" setting in the GUI config tool.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.