Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I got a WD MyBook Essentials the other day but after a week or so the drive physically broke.

I tried opening the case and replacing the drive with another SATA WD drive I had lying around. This seemed to work except Windows 7 drive manager didn't show any partitions (it does show the disk itself and the correct size) and said the disk needs to be initialized. When I tried to do so I got the message "The media is write protected."

Tried installing WD SmartWare but that doesn't even recognize the drive.

Also tried using gparted under Ubuntu but it came back with the message "I/O error reading /dev/sdb".

share|improve this question
    
I had the same problem but i ran the WD quick formatter and WD firmware updater and it allowed me to use it. So i now have the WD 1TB drive in my computer and my old seagate 500gb drive is in my mybook working fine :) –  user96547 Sep 4 '11 at 3:23

4 Answers 4

you have to format this HDD before use, sufficient with quick format, for HDD's where shouldn'd be instaled some Native OS

share|improve this answer
    
Thanks for your reply, but that's the problem ;) It won't even allow me to initialize the drive, let alone partition or format. –  PeterD Jul 21 '11 at 12:01
    
maybe I'm wrong carltonbale.com/… –  mKorbel Jul 21 '11 at 12:17
    
Thanks for the link. I checked it out, it had some good tips but unfortunately they didn't work for me. The drive remains "locked". –  PeterD Jul 22 '11 at 12:47

As far as I know the Hard Disks used in WD MyBook Essentials are encrypted (performed by the drive).

Therefore you can not just swap the used drive - I assume you have to use one that supports hardware encryption like the original one.

share|improve this answer
    
Hmm I was afraid of something like that. I'm not sure, the disk I tried replacing with is a WD500AAKS. My guess is it probably doesn't but Google didn't tell me much. Is there an easy way to find out, or a hard way for that matter? ;) –  PeterD Jul 21 '11 at 12:05
up vote 0 down vote accepted

Unfortunately never found an answer to this, the interface is still sitting gathering dust and the drives have found other homes in the mean time.

share|improve this answer

I discovered the work around for this. To make a new hard drive work with the old external enclosure you'll need to do the following:

  1. Connect the new HDD to the computer internally via the SATA interface.
  2. Under Disk Management, right click the disk and select "Convert to Dynamic Disk.."
  3. Connect the HDD to the My Book Essential USB interface card and it will no longer be write protected.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.