Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just installed Kubuntu. The hardware includes two current generation ATI graphics cards in crossfire configuration. I have only one monitor plugged in. Kubuntu's Display and Monitor settings correctly identifies that I have only one screen; the multiple monitors section says so directly.

Nevertheless, when I move my cursor past the right edge of the screen, it can move what appears to be approximately one full screen width beyond my visible desktop.

I have also observed one program centering a message in a location that appears to be centered at the right edge of my screen, i.e in the middle of my actual monitor and the imaginary monitor.

I guess there are some settings somewhere, used only by the mouse and this one program, that thinks there is a second monitor. How can I fix this?

Edit to add xrandr output:

Screen 0: minimum 320 x 200, current 1280 x 1024, maximum 1280 x 1280
DFP1 disconnected (normal left inverted right x axis y axis)
DFP2 disconnected (normal left inverted right x axis y axis)
DFP3 disconnected (normal left inverted right x axis y axis)
DFP4 disconnected (normal left inverted right x axis y axis)
DFP5 connected 1280x1024+0+0 (normal left inverted right x axis y axis) 375mm x 301mm
   1280x1024      60.0*+   75.0     72.0     70.0  
   1280x960       72.0     75.0     70.0     60.0  
   1152x864       72.0     75.0     70.0     60.0  
   1280x768       72.0     75.0     70.0     60.0  
   1280x720       72.0     75.0     70.0     60.0  
   1024x768       72.0     75.0     70.1     60.0  
   800x600        70.0     72.2     75.0     60.3     56.2  
   640x480        70.0     75.0     72.8     67.0     59.9  
DFP6 disconnected (normal left inverted right x axis y axis)
CRT1 disconnected (normal left inverted right x axis y axis)

...and xorg.cfg

Section "ServerLayout"
    Identifier     "aticonfig Layout"
    Screen      0  "aticonfig-Screen[0]-0" 0 0
    Screen         "aticonfig-Screen[1]-0" RightOf "aticonfig-Screen[0]-0"
EndSection

Section "Module"
    Load  "glx"
EndSection

Section "Monitor"
    Identifier   "aticonfig-Monitor[0]-0"
    Option      "VendorName" "ATI Proprietary Driver"
    Option      "ModelName" "Generic Autodetecting Monitor"
    Option      "DPMS" "true"
EndSection

Section "Monitor"
    Identifier   "aticonfig-Monitor[1]-0"
    Option      "VendorName" "ATI Proprietary Driver"
    Option      "ModelName" "Generic Autodetecting Monitor"
    Option      "DPMS" "true"
EndSection

Section "Device"
    Identifier  "aticonfig-Device[0]-0"
    Driver      "fglrx"
    BusID       "PCI:1:0:0"
EndSection

Section "Device"
    Identifier  "aticonfig-Device[1]-0"
    Driver      "fglrx"
    BusID       "PCI:2:0:0"
EndSection

Section "Screen"
    Identifier "Default Screen"
    DefaultDepth     24
EndSection

Section "Screen"
    Identifier "aticonfig-Screen[0]-0"
    Device     "aticonfig-Device[0]-0"
    Monitor    "aticonfig-Monitor[0]-0"
    DefaultDepth     24
    SubSection "Display"
        Viewport   0 0
        Depth     24
    EndSubSection
EndSection

Section "Screen"
    Identifier "aticonfig-Screen[1]-0"
    Device     "aticonfig-Device[1]-0"
    Monitor    "aticonfig-Monitor[1]-0"
    DefaultDepth     24
    SubSection "Display"
        Viewport   0 0
        Depth     24
    EndSubSection
EndSection
share|improve this question
    
Hmm... I assume that Display and Monitor uses xrandr. Paste the output of running the xrandr command. –  new123456 Jul 21 '11 at 15:31
    
Added xrandr output. –  slarpspark Jul 21 '11 at 16:47
    
Try deleting the second monitor section (line 18-23) out of xorg.conf and restarting X. –  new123456 Jul 21 '11 at 17:15

1 Answer 1

I found an answer elsewhere. Just replace the top part of the xorg.conf with this. Basically placing the other screen disjointed removes the ability for the mouse to traverse edges:

Section "ServerLayout"
    Identifier     "aticonfig Layout"
    Screen      0  "aticonfig-Screen[0]-0" 0 0
    Screen         "aticonfig-Screen[1]-0" 2000 0
EndSection
share|improve this answer
    
I have the same problem, but I effective have 3 screens and xorg.conf lists 3, while there appears to be a 4th one on the right (just for the mouse). Did you happen to find an alternative approach for your problem? Wherever I seek, I find your topics... –  user1111929 Dec 4 '13 at 12:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.