Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've recently been assigned to work on a diagnostic program done in C++ which communicates with a piece of electronic equipment. Our normal scenario involves communicating via an RS232 interface, but I've been asked to make our program work over ethernet, source code having been done in Visual Basic.

After much thrashing about trying to get the code to work and continuing to get 10049 Winsock errors when I tried to connect, I tried pinging the switch. From the computer the VB program is running on, I can see the switch via ping, nslookup, tracert, and pathping (I was going down the list of programs) and I can do this via URI or IP address. From my laptop, sending the same commands fails every time. They're both using the same network cable and the same USB-to-Ethernet device (I've been swapping them between tests) but one can see the switch and the other cannot.

I'm working on the programming end, but the ping results makes me think that there might be a network issue stymieing me. wry grin I'm not much of a network guy, so I'm appealing to expert assistance.

Both computers are running Windows XP if that helps.

The connection is to an "IP-RS8" device which then connects to our VCU-C units. Each unit is accessible via URI or IP address on the desktop computer we usually have connected to the units (it's running the older VB program that I was asked to lift the networking code from). The connection is made via a USB-to-Ethernet adapter so as to leave the regular Ethernet port available for connecting to the company network. Hmm... come to think of it, I've probably been confusing the issue, talking about pinging "the switch" rather than indicating that it's the devices. My apologies. Communication is generally done with a DLL that uses Winsock functions to make queries for data from the VCU and then to receive. I'm failing when connecting.

I haven't found anything on the firewall which should block these commands, but I'll keep poking. I don't know if it's potentially relevant, but on the desktop, the adapter maps to Local Area Connection 3 while on the laptop, it consistently maps to Local Area Connection 2. Currently reading up on DHCP.

IPConfig /all results:

Desktop

Host Name . . . . . . . . . . . . : AMERDAEXXXXXX
Primary Dns Suffix  . . . . . . . : amer.example.com
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No
DNS Suffix Search List. . . . . . : COMPANY.com
                                    amer.example.com
                                    atle.example.com
                                    cone.example.com
                                    apac.example.com
                                    scan.example.com
                                    bYX.example.com

Ethernet adapter Local Area Connection X:

Connection-specific DNS Suffix  . : amer.example.com
Description . . . . . . . . . . . : Broadcom NetXtreme XYxx Gigabit Controller
Physical Address. . . . . . . . . : YY-XX-YB-XX-XX-XX
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IP Address. . . . . . . . . . . . : XYY.XXX.XY.XXX
Subnet Mask . . . . . . . . . . . : XXX.XXX.XXY.Y
Default Gateway . . . . . . . . . : XYY.XXX.XY.X
DHCP Server . . . . . . . . . . . : XY.XXX.XXY.XX
DNS Servers . . . . . . . . . . . : XY.XXX.XXY.XX
                                    XY.XXY.XXY.XX
Primary WINS Server . . . . . . . : XY.XXX.XXY.X
Secondary WINS Server . . . . . . : XY.XXY.XXY.X
Lease Obtained. . . . . . . . . . : Thursday, July XX, XYXX XY:XX:XX AM
Lease Expires . . . . . . . . . . : Sunday, July XX, XYXX XY:XX:XX AM

Ethernet adapter Local Area Connection X:

Connection-specific DNS Suffix  . : 
Description . . . . . . . . . . . : ASIX axYYYYX USBX.Y to Fast Ethernet Adapter
Physical Address. . . . . . . . . : YY-XY-BY-YX-XY-AY
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IP Address. . . . . . . . . . . . : XY.Y.Y.X
Subnet Mask . . . . . . . . . . . : XXX.XXX.XXY.Y
Default Gateway . . . . . . . . . : XY.Y.Y.X
DHCP Server . . . . . . . . . . . : XY.Y.Y.XY
DNS Servers . . . . . . . . . . . : XY.Y.Y.X
Lease Obtained. . . . . . . . . . : Thursday, July XX, XYXX XY:XX:XY AM
Lease Expires . . . . . . . . . . : Tuesday, August YX, XYXX XX:XY:XY AM

Laptop

Windows IP Configuration

Host Name . . . . . . . . . . . . : AMERLAFYYXXYX
Primary Dns Suffix  . . . . . . . : amer.example.com
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No
DNS Suffix Search List. . . . . . : COMPANY.com
                                    amer.example.com
                                    atle.example.com
                                    cone.example.com
                                    apac.example.com
                                    scan.example.com
                                    bYX.example.com

Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix  . : amer.example.com
Description . . . . . . . . . . . : Intel(R) 82567LM Gigabit Network Connection
Physical Address. . . . . . . . . : YY-XY-BY-DY-XB-YX
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IP Address. . . . . . . . . . . . : XYY.XXX.XY.XY
Subnet Mask . . . . . . . . . . . : XXX.XXX.XXY.Y
Default Gateway . . . . . . . . . : XYY.XXX.XY.X
DHCP Server . . . . . . . . . . . : XY.XXX.XXY.XX
DNS Servers . . . . . . . . . . . : XY.XXX.XXY.XX
                                    XY.XXY.XXY.XX
Primary WINS Server . . . . . . . : XY.XXX.XXY.X
Secondary WINS Server . . . . . . : XY.XXY.XXY.X
Lease Obtained. . . . . . . . . . : Thursday, July XX, XYXX XX:XX:XX AM
Lease Expires . . . . . . . . . . : Sunday, July XX, XYXX XX:XX:XX AM

Ethernet adapter {XYXAAYXX-YEDY-XXYX-YYEX-BYXYXXYEEYEX}:

Connection-specific DNS Suffix  . : 
Description . . . . . . . . . . . : Nortel IPSECSHM Adapter 
                                     - Packet Scheduler iniport
Physical Address. . . . . . . . . : XX-XX-XX-XX-XX-YY
Dhcp Enabled. . . . . . . . . . . : No
IP Address. . . . . . . . . . . . : Y.Y.Y.Y
Subnet Mask . . . . . . . . . . . : Y.Y.Y.Y
Default Gateway . . . . . . . . . : 

Ethernet adapter Leaf Networks Adapter:

Connection-specific DNS Suffix  . : 
Description . . . . . . . . . . . : Leaf Networks Adapter
Physical Address. . . . . . . . . : YY-FF-FA-BC-YF-AY
Dhcp Enabled. . . . . . . . . . . : No
IP Address. . . . . . . . . . . . : X.XYY.XY.XX
Subnet Mask . . . . . . . . . . . : XXX.Y.Y.Y
Default Gateway . . . . . . . . . : 

Ethernet adapter Local Area Connection 3:

Media State . . . . . . . . . . . : Media disconnected
Description . . . . . . . . . . . : Bluetooth LAN Access Server Driver
Physical Address. . . . . . . . . : YY-FX-AX-YA-BY-CA

Ethernet adapter Wireless Network Connection 2:

Media State . . . . . . . . . . . : Media disconnected
Description . . . . . . . . . . . : Intel(R) WiFi Link 5300 AGN
Physical Address. . . . . . . . . : YY-XX-YA-CX-FC-YE

Ethernet adapter Local Area Connection 2:

Connection-specific DNS Suffix  . : 
Description . . . . . . . . . . . : ASIX ax88772 USB2.0 to Fast Ethernet Adapter
Physical Address. . . . . . . . . : YY-XY-BY-YX-XY-AY
Dhcp Enabled. . . . . . . . . . . : No
IP Address. . . . . . . . . . . . : XYX.XYY.X.X
Subnet Mask . . . . . . . . . . . : XXX.XXX.XXX.Y
Default Gateway . . . . . . . . . : 
share|improve this question

migrated from serverfault.com Jul 21 '11 at 14:08

This question came from our site for professional system and network administrators.

    
You're question doesn't jump out at me, so I'm guessing as to what you mean. So you have a USB to Ethernet addapter; On the computer you're doing your programming on, you have network access just fine, but your program doesn't work. You want to make sure this isn't an issue with networking, so you change the USB connection to your laptop and your laptop has problems connecting to the network. So your question is, "How do I make sure this isn't a networking issue?" –  Nixphoe Jul 21 '11 at 13:59
add comment

2 Answers

You say you are pinging the switch? Is the switch a managed switch with a dedicated IP address?

Add an exception for the pings on the firewall (or disable) of the computer that cannot be pinged. Are the computers on the same subnet (check the IP addressing of both systems)? Are there any static routes that are preventing the traversing (from command line run "ROUTE PRINT")?

share|improve this answer
add comment

Check the firewall settings. Check to make sure that your laptop is obtaining an address from DHCP (a duplicate address would indicate the problem).

Can you ping the gateway on the network?

Run ipconfig /all to find out some of this information.

Lastly, grab zenmap (which is a GUI frontend to port scanning tool nmap) and port scan the device to see what's available to you. Another good tool (other than telnet) I use to test connectivity to a specific TCP port is tcping, which basically tries to connect then disconnects on a specific port.

When programming, did you have to code within a described protocol or is the program/your program just a front end to telnet communication? If so, please opt for SSH, as telnet will send commands in plain text, and this is always bad and never good.

: http://nmap.org/dist/nmap-5.51-setup.exe : http://www.elifulkerson.com/projects/tcping.php

share|improve this answer
    
I'm freaking out! Please for anonymize your IP configs! The Internet now knows critical information about your network infrastructure! I'm having a stroke over here! Also, answer my questions, like "can you ping the gateway on the network?" Post a tracert towards the device itself. –  mbrownnyc Jul 21 '11 at 18:48
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.