Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I regularly use RDP to connect to my home computer (WinXP Pro SP3) from work (WinXP Pro SP3). My home computer has multiple users set up with Fast User Switching enabled. The problem is that my wife and kids are able to log in while I'm connected via RDP. There's nothing on the login screen to indicate that I'm logged in, much less a lock of some kind that prevents them from logging in.

So, is there something I can do to actually lock them out while I'm connected, or at least indicate that I'm logged in?

share|improve this question

If you know you are going to remote desktop in, couldn't you log into to your home PC on your account and lock it from there. So unless your wife and kids know your password they won't be able to login and it will give them an indication you're using the machine.

share|improve this answer
This won't work, because Fast User Switching allows multiple users to be logged in, but only allows one user to operate the computer at any given time. If someone else logs onto the local console, it will disconnect anyone who is remotely connected. – rob Mar 23 '10 at 0:10

I'd suggest only having your account logged in while you're actively using the computer, and logging out when it's safe for the family to use it. When someone else in your house goes to use the computer, they will be able to see whether or not you are logged in.

This alone won't prevent anyone else from logging in, but at a glance they'll know whether it's safe to use the computer, or if they will have to face your wrath.

If you want to prevent others from logging in while you're using the computer from work, you can log them out, then disable their accounts temporarily. It's a little bit of a hassle (not to mention, a little evil), but it should accomplish what you're hoping to achieve.

share|improve this answer

Does your RDP support multiple users? Im guessing you got disconnected when someone else logged in.

In others case you can simply disable Remote Desktop Sharing whenever you log in.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .