Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

It appears that the ~/Sites directory no longer exists in OS X Lion. I preferred working on sites there than in /Library/WebServer/Documents. Is there any way to change it back, or set it up so that I can work on sites in ~/Sites and have the files automatically moved to /Library/WebServer/Documents?

share|improve this question
1  
I still have ~/Sites. I upgraded, did you do a clean install? –  William Jackson Jul 21 '11 at 19:23
1  
I don't have Sites in a clean install. –  Vervious Jul 21 '11 at 21:00
    
Can you just create ~/Sites and put files there? –  Mark Jul 21 '11 at 21:04
    
I did a clean install. But creating a "Sites" folder fully restores the missing functionality. You can go to imac.local/~user as you used to be able to do and you get a custom icon. I guess they just figure most people don't need it and those that do can create it. –  Oliver Taylor Jul 21 '11 at 22:51
add comment

3 Answers

If you enable Web Sharing in System Preferences, you now have the option to create a Personal Website Folder which essentially creates a ~/Sites directory.

share|improve this answer
2  
I do not see the option to enable Web Sharing –  pal4life Dec 21 '12 at 14:42
    
Internet Sharing –  WHITEB0X Nov 19 '13 at 0:41
add comment

You can link them together with a Symlink:

cd ~
ln -s /Library/WebServer/Documents Sites

This will make ~/Sites behave as a alias of /Library/WebServer/Documents on the filesystem level, so it should work for all applications that you use.

The ideal way to fix this would be to fix the configuration for the webserver to support ~/Sites for each user again, but if you're the only user using the system, this method described here should work.

share|improve this answer
1  
Thanks. See my comment above. I just created a "Sites" folder and full functionality was restored. –  Oliver Taylor Jul 21 '11 at 22:52
2  
@Oliver That's great! If you post it as an answer, you can accept it (which is allowed (and encouraged!) here if it is indeed the solution). –  Darth Android Jul 22 '11 at 13:59
add comment

Just turning on "Web Sharing" doesn't add the Sites folder. You have to also click the "Create Personal Website Folder" to the right.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.