Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

In OS X Lion, is there a way to disable rubber-band scrolling? This is the bounce effect when the content pane is scrolled beyond the top or bottom edge of the window. This only occurs with a trackpad.

share|improve this question
    
Do not post the same question on multiple sites. –  Daniel Beck Jul 24 '11 at 17:17
    
Is there a cross posting feature? –  Wavy Crab Jul 25 '11 at 1:14
    
No. Choose a site and stick with it, or ask a moderator to migrate your question when you don't get answers. –  Daniel Beck Jul 25 '11 at 7:08
    
And what's wrong posting the same question on multiple sites? –  Wavy Crab Jul 30 '11 at 0:22
    
Community consensus is to not allow it. –  Daniel Beck Jul 30 '11 at 1:06

3 Answers 3

Unfortunately the only way is to turn of inertia scrolling. System Preferences > Universal Access > Mouse & Trackpad > Trackpad Options > Scrolling > without intertia

share|improve this answer

Inertia scrolling is NOT the same as the elasticity effect when you reach the top or bottom of a page, in an app that supports it (like Safari 5.1.)

That being said, we have a built in way to turn off inertia scrolling. We do NOT have a way to turn off the elasticity effect, if we're using input devices that support gestures.

I have found this CSS snippet that apparently disables it:

body {
  overflow: hidden;
}

Now to figure out how to implement the CSS rule in every web page we visit... probably via a Safari extension, like QuickStyle or NinjaKit.

QuickStyle: http://canisbos.com/quickstyle

share|improve this answer
1  
Also see: mir.aculo.us/2011/07/29/… –  Josh Aug 24 '11 at 12:52

Disable rubberbanding, but not vanishing scrollbars:

defaults write -g NSScrollViewRubberbanding -bool false

... and restore:

defaults delete -g NSScrollViewRubberbanding

This does not impact Safari nor iTunes, which use their own always-on rubberband system (possibly not using NSScrollView at all, or forcing rubberbanding to be on).

(also, this belongs to http://apple.stackexchange.com)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.