Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

UltraVNC Server PC has Windows XP Professional and UltraVNC v1.0.8.2 using the SecureVNCPluginARC4.dsm plugin and has been running happily for some time. It sits on the Internet and is accessed directly through an ADSL router.

Client 1 has Windows XP Professional and UltraVNC v1.0.9.5 viewer and connects without issues.

Client 2 is a Windows 7 32 bit laptop also with UltraVNC v1.0.9.5 viewer and can't connect at all. It uses the same SecureVNCPluginARC4.dsm and rc4.key as Client 1. I've opened the firewall for the VNC viewer, and I tried disabling the firewall altogether, but it didn't help. When it tries to connect it just sits at "Negotiate Protocol Version" and both "bytes sent" and "bytes received" stay at 0 which would indicate something is blocking the connection.

Using the Windows 7 laptop, I can make VNC connections on the local network.

I suspect this is more of a Windows issue than UltraVNC, but I'm not sure what to try next and I have no experience with Windows 7. How do I fix this problem?


You're right Randolf, it is making the initial connection. When I tried it without the plugin it immediately complained about an invalid protocol.

It is using the correct port, I use a VNC settings file that I copied from the working client.

I connected from the Windows XP client PC and checked Event Viewer. It shows the successful connections from this client, but shows nothing from the failed attempts by the Windows 7 client. Something must be preventing the connection from completing.

I plan to update the server next time I'm at the site, but it's a long drive to get there so for the meantime it will have to stay on the old version :-(

share|improve this question

migrated from serverfault.com Jul 22 '11 at 3:04

This question came from our site for professional system and network administrators.

    
There were some important changes after v1.0.8.2 if I'm recalling correctly, but this shouldn't effect connecting. But just to rule this out, you should probably update your server to the newest version. –  Randolf Richardson Jul 22 '11 at 3:23
    
If you're seeing "Negotiate Protocol Version" then it means that a connection was successful. The first bytes sent back-and-forth with the RFB protocol (RFB {Remote Frame Buffer} is the name of the VNC protocol) include version information -- if some other protocol answers, this stage will definitely fail, so make sure you've got UltraVNC listening on the correct TCP port numbers (normally 5900 by default, and 5800 for the HTTP-served Java Applet client). –  Randolf Richardson Jul 22 '11 at 3:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.