Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When copying files (~1MB) from the host machine (W7 x64 Ultimate) to XPMode, the copy is very slow - ~8KB/s.

Copying the file to an actual network share (using explorer running on the host machine), then copying from the network share to the XPMode folder (using explorer running in XPMode) is quite fast.

Any ideas why this happens? And maybe even what can be done against?

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

First I found this, which seemed to work: (the registry change should be done on the host (Windows 7) machine, not the XP machine)
Workaround for Windows VPC networking slowness between host and guest

Then a coworker showed me how to disable this without the registry edit: Start->Control Panel->Network and Sharing Center->Chagne Adapter Settings->Dbl-click 'Local Area Connection'-> Properties->Configure->Advanced-> Disable TCP Checksum Offload and UDP Checksum Offload (one each for IPv4 and IPv6)

This worked for me. I hope it helps you.

Source

share|improve this answer
    
Hmm... that catapults me up to 36 KB/s... –  peterchen Jul 22 '11 at 9:48
add comment

Since admintech's answer helped some, add these related commands to your try.

From an elevate command prompt run these:

netsh interface tcp set global rss=disabled

netsh interface tcp set global chimney=disabled

netsh interface tcp set global autotuning=disabled

http://support.microsoft.com/kb/951037

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.