Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

After a couple of years of down- and uploading files (mostly by torrents) directly to the hard drive of my workstation, I recently set up a NAS to handle storage and the read/write load. That, of course, took a lot of strain off my workstation which is quite old and couldn't handle the disk load of my 100 Mbps internet connection without grinding the OS to a halt.

However, I am still experiencing problems with download speed dropping, and at those times µTorrent reports "disk overload" of 30-90%. Most of the time I am able to get download speeds of about 10.3 MB/s without problems for a short while, until the disk overload starts. The workstation and NAS is connected through a wired gigabit router.

My workstation doesn't show any great activity at all, since it's all on the RAM and CPU to transfer the files to the NAS. I checked the resource monitor (Windows 7) and the disk activity seldom exceeds 200 KB/s when I max out my internet connection.

I've checked with the NAS (running FreeNAS 8, and accessed via Samba on a UFS-formatted RAID-5) and it shows a system load average of about 0.10-0.30 under full download speeds. The smbd-process uses roughly 6-10% of the CPU power (samba is truly inefficient) so that shouldn't be a problem.

One could imagine that the problems could be with my LAN. I checked my router which is running on an average system load of ~0.3. When I transfer files in a regular fashion, from my workstation to the NAS, I'm getting speeds of 60-80 MB/s. Of course this leads me to believe that the problem is caused by the fragmented way torrent downloads work. But shouldn't a dedicated computer be able to handle many reads and writes without dropping to 12% of what it can manage with a single file transfer?

I have lowered the µTorrent connection settings a bit, which did nothing.

Does anyone have any idea of what I could do to fix these issues?

share|improve this question
up vote 5 down vote accepted

A decent workaround that I've been using is to change the disk cache in utorrent. Go to

Preferences->Advanced->Disk Cache

and check

Override automatic cache size and specify the size manually (MB):

Set the value according to how much ram you can spare/want to use. I've set mine to 300 and it's considerably lowered the disk overload issues I'm seeing.

share|improve this answer
    
Yeah, I've got that set by default to 512 MB. – cmbrnt Jul 22 '11 at 11:38
    
Instantly fixed the disk overload issue for me, barely got ~1MB/S towards my ZFS based NAS in RAID1, now i am getting ~11MB/S and no load issue. I set the cache to 512. – t.mikael.d May 29 '12 at 18:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .