Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am telnet using OpenVms and there was no vim by default. I have to port a vim into OpenVms by myself. I don't have control of the machine itself.

I downloaded a copy of vim72 for OpenVms and unzip it to a directory, then define symbol to link to the VIM.EXE.

TGSM_OPR> sh sym vim
  VIM == "$GSMACPTUSER:[USER.TGSM_OPR.AXP.RAYMOND_LAM.VIM72]VIM.EXE"

I copied the vimrc file to the sys$login directory and started using vim.

I found that I cannot use the backspace key, nor Ctrl+H work in some scenarios. If I start a new document, the backspace is working and I can backspace whenever I want. However, if I open a already existing file which have some text inside, I cannot backspace those text.

I don't know which .vimrc it is using.

I found there is a GSMACPTUSER:[USER.TGSM_OPR.AXP.RAYMOND_LAM.VIM72]VIMRC.;6 . But after editting it, say add a line "set number" to it, it doesn't give the effect(no number).

Edit: I copy the content of vimrc. to .vimrc inside sys$login, and some function are working, but some don't. Showmode is working, Line number is not working, backspace not working, although I can use REPLACE(press insert twice) to overwrite the words.

Here is the content of the .vimrc I created in sys$login:

" An example for a vimrc file.
"
" Maintainer:   Bram Moolenaar <Bram@vim.org>
" Last change:  2008 Jul 02
"
" To use it, copy it to
"     for Unix and OS/2:  ~/.vimrc
"         for Amiga:  s:.vimrc
"  for MS-DOS and Win32:  $VIM\_vimrc
"       for OpenVMS:  sys$login:.vimrc

" When started as "evim", evim.vim will already have done these settings.

set showmode
set number
set tabstop=8
set shiftwidth=8

if v:progname =~? "evim"
  finish
endif

" Use Vim settings, rather then Vi settings (much better!).
" This must be first, because it changes other options as a side effect.
set nocompatible

" allow backspacing over everything in insert mode
set backspace=indent,eol,start
set backspace=2

if has("vms")
  set nobackup      " do not keep a backup file, use versions instead
  hi search ctermbg=LightBlue
  let Tlist_Ctags_Cmd="vim:ctags.exe" " for taglist plugin
else
  set backup        " keep a backup file
endif
set history=50      " keep 50 lines of command line history
set ruler       " show the cursor position all the time
set showcmd     " display incomplete commands
set incsearch       " do incremental searching

" For Win32 GUI: remove 't' flag from 'guioptions': no tearoff menu entries
" let &guioptions = substitute(&guioptions, "t", "", "g")

" Don't use Ex mode, use Q for formatting
map Q gq

" CTRL-U in insert mode deletes a lot.  Use CTRL-G u to first break undo,
" so that you can undo CTRL-U after inserting a line break.
inoremap <C-U> <C-G>u<C-U>

" In many terminal emulators the mouse works just fine, thus enable it.
if has('mouse')
  set mouse=a
endif

" Switch syntax highlighting on, when the terminal has colors
" Also switch on highlighting the last used search pattern.
if &t_Co > 2 || has("gui_running")
  syntax on
  set hlsearch
endif

" Only do this part when compiled with support for autocommands.
if has("autocmd")

  " Enable file type detection.
  " Use the default filetype settings, so that mail gets 'tw' set to 72,
  " 'cindent' is on in C files, etc.
  " Also load indent files, to automatically do language-dependent indenting.
  filetype plugin indent on

  " Put these in an autocmd group, so that we can delete them easily.
  augroup vimrcEx
  au!

  " For all text files set 'textwidth' to 78 characters.
  autocmd FileType text setlocal textwidth=78

  " When editing a file, always jump to the last known cursor position.
  " Don't do it when the position is invalid or when inside an event handler
  " (happens when dropping a file on gvim).
  " Also don't do it when the mark is in the first line, that is the default
  " position when opening a file.
  autocmd BufReadPost *
    \ if line("'\"") > 1 && line("'\"") <= line("$") |
    \   exe "normal! g`\"" |
    \ endif

  augroup END

else

  set autoindent        " always set autoindenting on

endif " has("autocmd")

" Convenient command to see the difference between the current buffer and the
" file it was loaded from, thus the changes you made.
" Only define it when not defined already.
if !exists(":DiffOrig")
  command DiffOrig vert new | set bt=nofile | r # | 0d_ | diffthis
          \ | wincmd p | diffthis
endif
share|improve this question
add comment

2 Answers

To find the places that your Vim is looking for vimrc files, execute

:version

and look at the lines about half to two-thirds of the way down the page. To see what files Vim is actually reading at startup, execute

:scriptnames

A vimrc should be at the top of that list. To see if a particular option has been set from your vimrc, say 'number' for example, execute

:verbose set number?

That command will show the value of the option and if it was set from some startup file, it will say, "Last set from <filename>".

The behavior of the backspace key differs between normal and insert modes. If you're still having problems with it, it would help to know exactly what steps you are taking and exactly what the results are.

share|improve this answer
    
When In Insert, the backspace won't move when it encounter a already existed word. For normal mode, I forget, I will check it out next Monday. –  lamwaiman1988 Jul 23 '11 at 3:03
    
As you probably know, backspacing over an existing word in insert mode is controlled by the 'backspace' option and setting it as you have in your vimrc should allow that, so that is another indication that your vimrc is not being read. –  garyjohn Jul 24 '11 at 21:13
    
:scriptname give me sys$login:.vimrc, and in that vimrc there are already a "backspace=2".... –  lamwaiman1988 Jul 25 '11 at 1:37
    
What does :verbose backspace? print? That will tell you if the setting in .vimrc is being overridden and may tell you if the setting in .vimrc is being ignored. –  garyjohn Jul 25 '11 at 4:03
    
backspace= (Nothing) –  lamwaiman1988 Jul 25 '11 at 4:17
show 2 more comments
up vote 0 down vote accepted

A solution was divided. I don't know the reason, but the below setting just work. It came up after trying many many different setting to call VIM.EXE.

  1. Assume the vim.exe reside in the folder $GSMACPTUSER:[USER.TGSM_OPR.AXP.RAYMOND_LAM.VIM72], there should be a example file of vimrc, in this case, its name is VIMRC_EXAMPLE.VIM;1, this is a clean copy of vimrc

  2. Copy VIMRC_EXAMPLE.VIM;1 to sys$login as .VIMRC. In my case, sys$Login is $GSMACPTUSER:[USER.TGSM_OPR.AXP]

  3. Use a dcl to define the symbol needed for vim. For example: login.com

  4. In the dcl file, there are 2 lines:

    $ VIM :== $GSMACPTUSER:[USER.TGSM_OPR.AXP.RAYMOND_LAM.VIM72]VIM.EXE

This is to define the VIM.EXE so that we can call VIM via "vim [file-spec]".

$ VIMRUNTIME :== $GSMACPTUSER:[USER.TGSM_OPR.AXP.RAYMOND_LAM.VIM72]

I believe this symbol tells VIM where to look for some configurations. This is very important.

  1. Run the dcl once and everything works! One can edit the .vimrc file in sys$login.
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.