Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using Windows 7 and I have 2 networks:

  • one wireless with internet connection
  • one wired with no internet connection

The computer is connected to both. The problem is that although in Network and Sharing center it shows that the wireless connection has internet, it also shows that the computer is not connected to the internet.

If I only connect with the wireless, I have internet connection, but when connecting to the wired one it just can't access the internet anymore. And on the wired network I also have a printer that I want to share, but I can't see it if the wireless is also connected.


I suppose that there is a setting for default connection. What I want is to be able to connect to the internet over the wireless network and also to see the shared printer over the wired network.

And very important: I don't want the users on the wired network to be able to access the internet through my PC and the wireless connection (I don't want something like a bridge).

share|improve this question

3 Answers 3

up vote 1 down vote accepted

Revised, as I did not understand your question totally at first: The reason is probably because of the metric I describe below, but in your case, you want to give preference to the wireless network. You will set it's metric to 1, and the LAN to 2, and move the wireless to the top of the binding order.

You should post your IPCONFIG/ALL as you have not posted enough information to help you with that part of the question, but you want to make sure that your IP addresses, subnet masks, and gateways are all correct.

To answer the second half of your question:

TCP/IP "SHOULD" automatically detemine that the wired connection is the fastest, but I have seen times where it does not do this correctly, especially if if gets plugged in after, and you already have a wireless connection, which is connected and active.

If you want to guarantee that the wired network gets preference, do the following:

Go into your Connection>Properties for both TCP/IPv4 and TCP/IPv6 (if in use)set the metric for your LAN connection to 2, and your Wireless to 1 (for most people, they would want these reversed). In the screenshot you can see where I set this for my wireless adapter. If you hit F1 right there, you can see this quote from the help file:

Automatic metric specifies whether TCP/IP automatically calculates a value for an interface metric that is based on the speed of the interface. The highest-speed interface has the lowest interface metric value.

Interface metric provides a location for you to type a value for the interface metric for this network connection. A lower value for the interface metric indicates a higher priority for use of this interface.

Then you can also change your binding order by opening Control Panel>Network and Internet>Network Connections>Advanced>Advanced Settings as in this screenshot:

share|improve this answer
    
No one can connect through your connection unless you actually set that up. –  KCotreau Jul 22 '11 at 11:37
    
I did not totally understand part of what you were asking, but I do now, and I revised my answer if you saw it earlier. –  KCotreau Jul 22 '11 at 12:01
    
It worked!! I did exactly as you explained! Thanks! –  avi3898 Jul 25 '11 at 6:11
    
@avi3898 Great. Thank you for marking the answer. –  KCotreau Jul 25 '11 at 10:19

Are you getting an IP Address from a DHCP server on both connections?

If you are, configure the DHCP Server on the Wired network to not send a default gateway.

If not, edit the TCP/IP v4 settings for your Wired network interface to remove the default gateway (set it to blank).

share|improve this answer

From my reading of this question, I think the accepted answer is wrong. The issue is that Windows 7 (and possibly other versions) only recognizes a connection without a gateway as an "Undentified Network" and labels it as a Public Network, which is why you can't share the printer. There is a snapin for the MMC that lets you get around this. See http://blog.kazmarek.com/2010/2/25/change-default-behavior-for-unidentified-network-in-vistawindows-server-2008windows-7/ NOTE that Windows 7 Home doesn't have this snapin! (Though an unsupported installer is out there.)

Setting the wired non-internet connection to a private network this way should allow the printer to be shared.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.