Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

So I've started emacs with

emacs -nw

And it looks the other way then the one I customized and start with

emacs &

How do I bring my settings to "emacs -nw" - and also how to work there? Arrow keys doesn't work - and so on. Also a menu - I can't use it - it as expected do not responce to mouse clicks. Do you have any docs about it?

share|improve this question

2 Answers 2

up vote 2 down vote accepted

If you are talking about colorization and similar changes emacs is limited by the power of the terminal or terminal emulator you are using and by the terminal you tell emacs you are using.

Check your terminal setting with printenv TERM, and check the capabilities of your terminal emulator in it's documentation.

If you are using a xterm, consider setting TERM=xterm, which generally supports colorization and some font changing.

share|improve this answer

As far as I know, only calls without "-nw" support mouse actions. I may be wrong because I have seen vim have some mouse support.

Arrow keys? I don't know why they dont work for you, so I support the answer asking that you check your TERM settings and add that a way out is to either try a different build of emacs, or forget your default terminal and fire up xterm & or rxvt & prior to any emacs -nw work.

To answer your question on menus... look here: http://stackoverflow.com/questions/191312/how-do-i-get-to-the-menu-in-emacs-in-console-mode

You'll get a dynamic pop-up that simulates your having pressed the menu-summoning Alt key and doing a text-mode navigation. For example, quitting emacs is as easy (or hard) as hitting F10 and pressing f and then q. The problem is that the default terminals on Macs, and Ubuntu 10.10 eat up that key press to trigger their own functionality, like the gnome-terminal menu or the MacOS Dashboard.

You have to turn off the feature depending on your OS or terminal's keybindings. Macs have a System Preference pane to do that, and gnome-terminal has preferences in the Edit menu. I don't remember if cygwin misbehaves and what the fix was, but I know it was working for me.

If you meant having a visible menu... it depends on your emacs version, whether you see one by default. On MacOS I don't, but on Ubuntu it shows up by default without any .emacs file configuration. You probably can make it work permanently by editing (or creating) ~/.emacs and adding the line (menu-bar-mode t) You can comment that out at any time by using the ;; comment marker. PS: You'll have the sad realization that this menu bar in your no-window mode is just a decorative gimmick, and does NOT take mouse input. So it's just there to show you indirectly the language mode it's using (by what menu headers change to as you switch from .sh files to .cpp and so forth)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.