Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to install wireshark on Fedora(latest version with gnome3) and I keep getting the above error.

I keep killing the offending process after finding it's pid using "ps aux | grep yum", but the same process spawns again with a different pid.

root 1605 0.0 3.4 54424 26228 ? SN 10:51 0:02 /usr/bin/python /usr/share/PackageKit/helpers/yum/yumBackend.py get-updates none

How can I properly kill this process, or use yum to install wireshark properly?

share|improve this question
    
What is the process? –  PriceChild Jul 22 '11 at 15:24
    
updated with the result of ps aux | grep yum to show process –  user77017 Jul 22 '11 at 15:44
add comment

4 Answers

up vote 5 down vote accepted

That is PackageKit attempting to update the yum database so that it can show you a desktop icon when there are updates to apply.

It should only run for short periods - if it is failing to complete then it suggests there is some sort of problem with your yum configuration such that it is hanging trying to update the status of one of the repositories or something.

share|improve this answer
    
unfortunately that actually makes sense in my case, the internet here is abysmal/filtered –  user77017 Jul 22 '11 at 16:40
2  
ok nevermind, I restarted and now I can use yum. I feel like I'm working on Windows. –  user77017 Jul 22 '11 at 16:59
    
@user77017 I feel like I'm working on Windows - Recompile your distribution to use a package manager other than yum. Should give you that Linux feeling. –  ta.speot.is Jul 25 '11 at 4:40
    
lol todda, recompiling is annoying and time consuming, I would rather the default package manager work properly with yum –  user77017 Jul 26 '11 at 20:29
add comment

If you really don't like PackageKit, you can remove it by running the following command as root:

 yum remove PackageKit

You can also disable PackageKit from checking for updates by running gpk-prefs from the terminal:

 gpk-prefs &disown

In the preferences window, change Check for updates to never.

share|improve this answer
add comment

Stop the daemon of packagekit with:

service packagekitd stop

I don't remember if the name is "packagekitd". I also don't remember if in the last versions of fedora PK is a daemon or only a user process.

If you want disable the process check the command "ntsysv" as root in a terminal and the autostart applications in your desktop preferences.

For your problem with the internet connection and the download of packages, check the plugin fastestmirror for yum. The configuration is very simple. Also use the presto plugin.

share|improve this answer
    
It doesn't work like that, at least on F15, though it might do on earlier versions. On F15 it is dbus activated, so it starts as soon as somebody (the Gnome control centre applet most likely) tries to talk to it over dbus. –  TomH Jul 25 '11 at 7:38
    
add comment

I found a way to correct this problem.

You can turn off the system auto update, and can resolve it.

In China, I tested it this way and it works well.

share|improve this answer
    
Hi and Welcome to Super User! Maybe you could explain how to do this to make your answer a little more detailed? Just a thought. –  slm Jul 1 '13 at 13:58
    
To disable packagekit: in terminal run gpk-prefs and select "Check for updates: Never ". –  Nav Jan 15 at 4:25
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.