Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I made a mistake and need to restore the File Folder's default action upon double-click. Right now it just activates the find. I cannot remove find or Command Prompt. I am an Administrator.

enter image description here

share|improve this question

5 Answers 5

On my XP System for File Folder there's a third Action in the list called "Open File Location". I'm not sure how to add it back through Edit File Type, but the following registry commands would do it. You can copy the following into a text file and save it as folder.reg. Afterwards you can right-click on the file and pick "Merge" from the context menu to add the entries (back) into your registry.

== folder.reg ==

Windows Registry Editor Version 5.00


[HKEY_CLASSES_ROOT\*\shell\Open File Location]
@="&Open File Location"

[HKEY_CLASSES_ROOT\*\shell\Open File Location\command]
@="\"explorer.exe\" /select,\"%1\""

Afterwards you should be able make "Open File Location" the default action -- if it isn't already -- using Edit File Type, where it should now (re)appear as one of the available Actions.

share|improve this answer
best I have been able to do so far is create a new action called open, with the program explorer.exe... Unfortunately your registry edit didn't fix my problem :( – staticx Jul 22 '11 at 18:13
You might have to reboot after merging the .reg file. – martineau Jul 22 '11 at 18:24
  1. choose your extension(none) and double click on it.
  2. click Advanced then click New...
  3. click Browse...
  4. choose Explorer from C:\WINDOWS
  5. type explorer on Action
  6. then click ok
  7. now the final step is-choose your explorer then click on set default then click close thats all
share|improve this answer

The default IS find. Also, it is something that I cannot delete either as an admistrator. Here is what that box looks like on a known-good system:

enter image description here

share|improve this answer
up vote 0 down vote accepted

I fixed the problem by going to this site and restoring my Windows XP File Association for Folder and Directory.

share|improve this answer

Click to Folder option in Open Folder , next Folder Types , Choose Folder Extentsion this is your choise, then click for Advenced button, click for new, action = open and browse to c windows file to open explorer.exe and click open and comback to previous window and click for setdefult then click ok. End enjoy now.

share|improve this answer
Hi Avijit, this answer seems to be very similar to another answer posted, and another answer has been accepted on this (old) question. Perhaps you could edit your answer to improve the formatting and clarify what makes it more useful than other answers posted? Thanks – bertieb Aug 1 at 12:22

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.