Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I installed Oracle 11g on my Win 7 x64 PC. When I look in Data Sources (under Administrative Tools in the Control Panel) and click on the System DSN tab, I can see the Oracle driver listed ("Oracle in OraClient11g_home1").

The problem, though, is when I try to create a link table in Microsoft Access. I click the 'external data' tab, then click the 'more' drop down and choose "ODBC database". From there I choose "Link to the data source by creating a linked table" and choose the "Machine Data Source" tab on the following dialog window.

From there, I click the 'New' button (to create a new data source) and choose the 'System Data Source' radio button. Now, usually in the resulting list I should be able to see the Oracle 11g data source, but it's not showing up in my list. I'm just wondering if anyone else has run into System DSNs not showing up and what they may have done to remedy the situation.

share|improve this question
add comment

2 Answers

up vote 2 down vote accepted

Well, it turns out that the problem stems from my 11g driver being 64-bit and my Microsoft Access being 32-bit. Basically, Access can't "see" the 64-bit driver.

share|improve this answer
add comment

If you add it as a User DSN rather than system you get to see it listed in Access, but this time you get a useful(ish) error: The specified DSN contains an architecture mismatch between the Driver and the Application.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.