Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I VPN to my work, and then I terminal server into my computer.

Everything works fine in relation to the VPN access, but locally I can't access the internet.

How can I fix this?

share|improve this question

5 Answers 5

up vote 34 down vote accepted

What you are looking to do is called split tunneling. If you are using a Microsoft PPTP VPN, you need to uncheck "Use default gateway on remote network" in the TCP/IPv4 advanced settings for the VPN connection.

If you are using another VPN client, you need to look for something related to split tunneling in the VPN client's documentations. Please note that some VPN's allow the administrator to disable split tunneling.

enter image description here

share|improve this answer
1  
Of course, you may need to do the same for IPv6 one day, too :-) –  Eyal Aug 28 '12 at 8:26
    
Worked well for me =) –  afreeland Apr 15 '13 at 12:47

Once you connect to the VPN, all the requests go through the VPN . You could delete the routes for particular sets of IPs (say your home router) using the route command which is usually not suggested because of security issues (this is the case usually, not Windows 7 though)

share|improve this answer

If the computer has connectivity to both the internet and the corporate VPN at the same time, and the computer is compromised in some way, or deliberately configured to bypass security, the computer can act as an unauthorized bridge between the public internet and corporate LAN.

The default behavior of almost all VPN software is therefore to isolate you from the public internet through routing, firewalling, layered service providers (windows only), and other technologies. Whether this can be changed or not depends on the product in question - some of them go to great lengths to make sure that someone doesn't find a creative solution to reenable internet access while the VPN is running.

The best workaround I've found if you have to connect to a VPN frequently is to have a virtual machine dedicated to VPN access - this method won't be blocked by VPN software, and it still keeps reasonably good separation between the internet and the corporate network.

share|improve this answer

I've been dealing with this for whole day and finally found resolution. Here is how:

  1. First issue: I couldnt connect to internet after I established my VPN .
  2. Resolution: I have disabled/unchecked "Use default gateway" checkbox on TCP IPv4 properties (VPN Connection Settings => Network => Internet protocol (TCP/IPv4) => properties => Advanced => Use default gateway on remote network)
  3. Second issue: after that althought my internet was working perfectly I could not connect to resource I need on that remote network (reason for VPN in first place :)
  4. Resolution: manually add route to routing table. This is how:
  5. a: First check what IP is assigned to you when you connect to VPN (mine was 10.30.0.12 so default gateway should be 10.30.0.1) and the resource that you need to access via VPN with subnet mask (mine was 172.18.0.19 255.255.255.255)
  6. b: after that you have all needed information to set up route manually (as descibed here http://support.microsoft.com/kb/317025). Mine manual route was (just enter it in command prompt):

    route -p add 172.18.0.19 mask 255.255.255.255 10.30.0.1

and thats it!!! :) Hope it helps!

share|improve this answer

This article may help: http://social.technet.microsoft.com/Forums/en/w7itpronetworking/thread/e6f831e4-cc4e-490f-a774-f3bda55a26e3

share|improve this answer
1  
Good and relevant article, but perhaps you could summarise it here rather than just giving the link? –  Simon W Mar 27 at 11:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.