Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have Windows 7 64 bit OS, I was just using Eclipse Helios, before I restart my pc, after the restart I am not able to use eclipse anymore. when I click on the eclipse icon, it opens but while loading it just stuck there, and when I click on it, I get the following message: JAVA (TM) Platform SE is not responding.

So, does anyone know what should I do?

share|improve this question

migrated from stackoverflow.com Jul 23 '11 at 1:25

This question came from our site for professional and enthusiast programmers.

    
you need to install a proper version of JAVA SDK check out eclipse compatiblity with x64bit . I think there is no eclipse x64 , so you need to install only JAVA SDK x86 and remove the x64 version –  Gaurav Shah Jul 22 '11 at 10:14
    
what did you change before that restart? –  Agent1891 Jul 22 '11 at 10:15
    
Did you apply any changes to the OS, e.g. Java Upgrade? –  home Jul 22 '11 at 10:16
    
I didnt change anything, it was working perfectly. –  Nima Jul 22 '11 at 10:28
    
A lot could be said about operating systems on which you can install Java without needing to have the admin password and which won't pollute other user accounts. I did manage to get similar issues on Linux and after getting stuck for a bit too long I did: a) save all my files (they're saved regularly anyway) and then b) delete all trace of the user account and c) re-create the user account and re-install Java + my IDE + all the rest. Pretty extreme, but on a system where you decide who's the boss, it's pretty failsafe. It's the b) part which is problematic with Windows. –  Weezy Jul 22 '11 at 11:26

2 Answers 2

Nima, Are you on a 64 bit version of the JDK and 64 bit version of Helios? . If not try having both on 64 bit, so that you can leverage your OS. Also, edit your eclipse.ini file to launch it pointing to a specific vm. eg :

-vm
myjdk/1.6.0_22/bin/javaw.exe

[SOLVED] Issue resolved with deleting the .snap file from yourworkspace\.metadata\.plugins\org.eclipse.core.resources

Explanation for the snap file : While Eclipse is running, information about what has changed in the workspace is incrementally logged into various "snapshot" files (including .snap). On normal Eclipse shutdown, the complete workspace state is saved and the .snap files are deleted. When Eclipse crashes, the snapshot files are used during the next startup to recover from the crash.

So, it appears that some error is occuring that is causing Eclipse to crash. Then, there is an error recovering from the crash on the next startup. These are quite possibly unrelated problems, but by manually deleting the snapshot file you are tricking Eclipse into thinking that a crash did not occur, so the crash recovering routines do not run.

from http://www.eclipse.org/forums/index.php/mv/msg/39563/129039/#msg_129039

share|improve this answer
    
I was using the same version of eclipse for about a month now, it was working just fine, I I was working with a VM file that I had within my eclipse, i was trying to get a webpage at my local host, I started tomcat and then in eclipse build ant, but I could get webpage at my local host, so I restart my pc, now when I run tomcat and when I go to my local host I can see the web page, but I cant open eclipse, I dont want to isntall it again because then I have to import so many things that would take me 3 hours or more to do. this is exactly what happend to me!! –  Nima Jul 22 '11 at 10:31
    
You can try using eclipse -clean to try launching up again. Also try deleting the .snap file in yourworkspace\.metadata\.plugins\org.eclipse.core.resources –  Ajay George Jul 22 '11 at 10:43
    
There is an eclipse bug filed under the same exit code. : bugs.eclipse.org/bugs/show_bug.cgi?id=319517. Are you on 6u21 jdk ? –  Ajay George Jul 22 '11 at 11:01
    
i have this version 1.6.0_26. –  Nima Jul 22 '11 at 11:07
    
I am not sure how to fix the bug. –  Nima Jul 22 '11 at 11:07

Reinstall eclipse and/or Java Runtime Environment. You can install either 32/64 bit version, but if you run eclipse 32 bit you need 32 bit JRE, with eclipse 64 bit, 64 bit JRE is required.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.