Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've set up Ubuntu 11.10 in a VirtualBox VM based off the alpha-2 ISO and trying to switch from Unity to Gnome 3. When I select GNOME from the login screen and log in, a popup appears saying

'Failed to load session 'gnome'".

I've got many GNOME packages installed, such as gnome-session. What is missing? Is this supported yet?

share|improve this question
    
Are you still having this problem now that 11.10 has been released? –  MDCore Nov 19 '11 at 19:44
    
@MDCore, no, it's all working fine. –  Blair Zajac Jan 17 '12 at 7:17
add comment

4 Answers

The GNOME 3 FAQ states:

To get the GNOME 3 experience, you need hardware acceleration.

So, if you are looking to use GNOME in your virtual box, you have to enable hardware acceleration for it.


But, fear not. Developments are going on to make sure that GNOME doesn't have to rely on GPU hardware and soon enough, through LLVMpipe, you should be able to get GNOME experience in your virtualbox without having to enable hardware acceleration.

It's now possible to run the GNOME Shell with Mutter but not having to rely upon any GPU hardware driver! Software rendering is now working with GNOME Shell rather than any fall-back thanks to improvements with Gallium3D's LLVMpipe.

share|improve this answer
add comment

You need to install gdm:

$ sudo apt-get install gdm
share|improve this answer
1  
You should not need to use GDM to launch Gnome3. –  Simon Sheehan Jul 26 '11 at 23:40
add comment

As indicated on the Gnome site, you can go to here to install Gnome 3 in Ubuntu. The link should load the Ubuntu Software Center.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.