Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

After helping a neighbor securing his network, one of his computers was suddenly not able to access either internet nor the router. Note that it was possible to connect to the network and obtain an IP-address via DHCP, but nothing else worked.

When disabling encryption, everything worked fine once again. Also tried both WPA and WPA2 settings in both router and on the computer, with no success. Another computer was able to connect without any issues, I'm quite sure the passkey is correct, and there is no active MAC filter.

The computer which could not connect ran Windows Vista, the router was a Linksys/Cisco E1000. I cannot think of anything other than a driver or network card hardware issue, but is there anything else I may have forgotten?

share|improve this question

1 Answer 1

You're right, it's almost certainly a bug in the wireless client card or driver. WPA and WPA2 require the driver to be able to handle a different encryption key for multicasts and broadcasts, and if it doesn't do it right, ARP (which is a critical low-level protocol that uses broadcasts) can break.

Make sure your neighbor has the latest firmware on his E1000, and the latest driver for his wireless card.

Also, name and shame the make, model, chipset vendor, driver version, etc. of the wireless card with the problem.

By the way, you didn't do anything to change/override his wireless MAC address, did you? Because if you did, and you accidentally set a fake MAC address that has the multicast (group) bit set (the 1's place in the first byte), then I could see that possibly causing a problem like this.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.