Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My computer recently had a hardware upgrade and now runs on Windows 7. I decided to install Ubuntu 11.04 as dual boot using the ISO I got from ubuntu.com downloaded onto my USB stick.

Restarting with the USB stick, I was able to install Ubuntu 11.04 choosing the option:

Install Ubuntu 11.04 side by side with Windows 7 (or something like that).

No errors were encountered on installation. However on restarting, there was no GRUB; the system went straight into Windows 7.

Looking for answers, I found these:

Following their instructions, I got:

Boot Info Script 0.60 from 17 May 2011

============================= Boot Info Summary: ===============================

=> Windows is installed in the MBR of /dev/sda.
=> Syslinux MBR (3.61-4.03) is installed in the MBR of /dev/sdb.
=> Grub2 (v1.99) is installed in the MBR of /dev/sdc and looks at sector 1 of
the same hard drive for core.img. core.img is at this location and looks
for (,msdos7)/boot/grub on this drive.

sda1: __________________________________________________ ________________________

File system: ntfs
Boot sector type: Windows Vista/7
Boot sector info: No errors found in the Boot Parameter Block.
Operating System:
Boot files: /grldr /bootmgr /Boot/BCD /grldr

sda2: __________________________________________________ ________________________

File system: ntfs
Boot sector type: Windows Vista/7
Boot sector info: No errors found in the Boot Parameter Block.
Operating System: Windows 7
Boot files: /Windows/System32/winload.exe

sdb1: __________________________________________________ ________________________

File system: vfat
Boot sector type: SYSLINUX 4.02 debian-20101016 ...........>...r>....... ......0...~.k...~...f...M.f.f....f..8~....>2}
Boot sector info: Syslinux looks at sector 1437504 of /dev/sdb1 for its
second stage. SYSLINUX is installed in the directory.
The integrity check of the ADV area failed. According
to the info in the boot sector, sdb1 starts at sector
0. But according to the info from fdisk, sdb1 starts
at sector 62.
Operating System:
Boot files: /boot/grub/grub.cfg /syslinux/syslinux.cfg /ldlinux.sys

sdc1: __________________________________________________ ________________________

File system: ntfs
Boot sector type: Windows XP
Boot sector info: No errors found in the Boot Parameter Block.
Operating System:
Boot files:

sdc2: __________________________________________________ ________________________

File system: Extended Partition
Boot sector type: -
Boot sector info:

sdc5: __________________________________________________ ________________________

File system: swap
Boot sector type: -
Boot sector info:

sdc6: __________________________________________________ ________________________

File system: swap
Boot sector type: -
Boot sector info:

sdc7: __________________________________________________ ________________________

File system: ext4
Boot sector type: -
Boot sector info:
Operating System: Ubuntu 11.04
Boot files: /boot/grub/grub.cfg /etc/fstab /boot/grub/core.img

sdc8: __________________________________________________ ________________________

File system: swap
Boot sector type: -
Boot sector info:

Going back into Ubuntu and running sudo fdisk -l , I got these:

ubuntu@ubuntu:~$ sudo fdisk -l

Disk /dev/sda: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x0002f393

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1          13      102400    7  HPFS/NTFS
Partition 1 does not end on cylinder boundary.
/dev/sda2              13       19458   156185600    7  HPFS/NTFS

Disk /dev/sdb: 2011 MB, 2011168768 bytes
62 heads, 62 sectors/track, 1021 cylinders
Units = cylinders of 3844 * 512 = 1968128 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x000f2ab9

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *           1        1021     1962331    c  W95 FAT32 (LBA)

Disk /dev/sdc: 1000.2 GB, 1000202043392 bytes
255 heads, 63 sectors/track, 121600 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00261ddd

   Device Boot      Start         End      Blocks   Id  System
/dev/sdc1   *           1       60657   487222656+   7  HPFS/NTFS
/dev/sdc2           60657      121600   489527681    5  Extended
/dev/sdc5          120563      121600     8337703+  82  Linux swap / Solaris
/dev/sdc6          120073      120562     3930112   82  Linux swap / Solaris
/dev/sdc7           60657      119584   473328640   83  Linux
/dev/sdc8          119584      120072     3923968   82  Linux swap / Solaris

Should I proceed and do the following?

  • Assuming Ubuntu 11.04 was installed on device sdb1, do this:

    sudo mount /dev/sdb1 /mnt
    
  • Then do this:

    sudo grub-install--root-directory=/mnt /dev/sdb
    

    Notice there are two dashes in front of the root directory, and I'm not using sdb1 but sdb.

  • Since the command in step 15 had reinstalled Grub 2, now we need to unmount the /mnt (i.e. sdb1) to clean up.

  • Do this:

    sudo umount /mnt
    

    Reboot and remove Ubuntu 11.04 CD/DVD from disk tray. Log into Ubuntu 11.04 (you have no choice but it will make you log into Ubuntu 11.04 at this point).

  • Open up a terminal in Ubuntu 11.04 (using real installation, not live CD/DVD). Execute this command:

    sudo update-grub
    
  • Reboot the machine.

share|improve this question
    
Are you sure it's --root-directory? It doesn't show up in the manpage, and grub-install complains when I give it that option. Did you mean --boot-directory? –  Nick ODell Nov 13 '12 at 18:15
add comment

3 Answers

After three days, I decided to reformat, reinstall windows 7 (first), then ubuntu following these instructions.

Today, I have a dual boot pc running ubuntu 11.04 by default, and windows 7.

What was different this time, was that I partitioned my hard drive using gparted while inside ubuntu trial mode, then installed ubuntu from there. Immediately after the reboot, I got my grub.

share|improve this answer
add comment

Next time if you want to use the Windows bootloader there are tools out there to allow booting linux from windows. Otherwise you can load a recovery linux CD and reinstall Grub.

share|improve this answer
add comment

You can also boot into live mode and use Ubuntu Boot Repair.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.