Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I had the following configurations (taken after installing windows) enter image description here

after I installed windows 7, I can't access "data drive" or "virtual drive" from windows or from ubunut live cd.

I also tried fixing MBR using the process described RecoveringUbuntuAfterInstallingWindows here, but that also fails.

Help please I have lots of valuable data on "Data drive".

Thanks,

share|improve this question

migrated from serverfault.com Jul 24 '11 at 7:18

This question came from our site for professional system and network administrators.

    
as you can see there is some thing that seems wrong in the picture, its saying Partition type is "W95 FAT32" but the type is "EXT 4". something seems messed up. –  Umair Ahmed Jul 24 '11 at 5:07
add comment

2 Answers

Windows cannot read ext4 partitions, so that is normal.

As for the partition type it is indeed suspicious, if you are very certain it is supposed to be a linux partition, go ahead to change the partition type and mount it.

Also, it would more helpful if you can post the commands you tried in the terminal window as well as the output you received.

share|improve this answer
    
I think the partition type was a fat32... I reformatted them to fat32 so that when i install windows it could be accessible. please tell me how to change type? –  Umair Ahmed Jul 24 '11 at 6:20
    
okay, were you able to access the partitions in ubuntu after you reformatted it to fat32? When was the last time you were able to boot into Ubuntu? Was it after the reformat? –  prusswan Jul 24 '11 at 6:24
    
yep... I have been using the partition for 3-4 months without any problem whatsoever –  Umair Ahmed Jul 24 '11 at 6:25
    
Are you able to boot into Ubuntu with your current configuration? –  prusswan Jul 24 '11 at 6:28
    
okay that might be of some help... using the terminal i saw its mounted, but when i try ls into it, it say "ubuntu@ubuntu:~$ ls /media/virtual/ ls: cannot open directory /media/virtual/: Permission denied " –  Umair Ahmed Jul 24 '11 at 6:29
show 3 more comments

Okay i managed to resolve it, sharing for others who ran into the same problem. Some how the partition need sudo access to browse. so nautilus wont work unless its launched with sudo rights.

do the following

ubuntu@ubuntu:~$ sudo nautilus /media/data/
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.