Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I enjoyed using VNC from my iPad to my Mac Pro running Snow Leopard without issues. Since upgrading to OS X Lion, I am no longer able to log in remotely.

I can connect, but I now see the OS X login screen instead of my desktop. I can't type my password either.

I read that changes to the Apple Remote Desktop (ARD) protocol in Lion have rendered VNC (aka Screen Sharing) unusable in many cases. Does anyone have a workaround? I'm using Mocha VNC Lite on my iPad.

share|improve this question

2 Answers 2

Seems like a feature not yet available in Mocha VNC. Other clients seem to work now, so it's probably just a matter of time for Mocha VNC to receive an update.

You need to send username and password over VNC for authenticating. This answer seems to suggest a solution:

[...] by making a simple macro: #T username (no space) then your password (no space) #R. When you see the login screen recall this marco and then press the enter arrow in VNC and you will log into Lion.

share|improve this answer
    
Unfortunately this didn't work for me. I'm still on the hunt for a free VNC client for iPad that works with Lion. –  Mark Richman Jul 24 '11 at 17:17
    
Hm, you might want to give the developers some time to catch up. In the meantime I heard that Remoter works, and it currently is only $ .99 –  slhck Jul 24 '11 at 17:20
    
The screens app from edovia does work well - mac and iOS versions. –  bmike Aug 15 '11 at 21:20

One workaround would be to use the vanilla VNC server instead of the "Apple" one that requires both a username and password to authenticate.

If you go into System Preferences->Sharing and turn off the "Screen Sharing" service, then turn on "Remote Management" and click "Computer Settings" you can enter a password only (which is how most VNC client expect to authenticate). VNC Server in OS X

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.