Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm having troubles on my local dev environment with Chrome since an unknown moment in the past, some request (I would say about 90% of them) are really slow, it takes about 10 secs to start transfering data.

This is what my Network inspector looks like.

I'm running Mac OS X (Lion, but it's been happening before) and MAMP as local web server. It also happens with Apache2+PHP5 installed through MacPorts.

It only happens on Chrome, the web server works as expected on Safari and Firefox. My about:version says this:

Google Chrome 12.0.742.122 (Official Build 91910)

I tried enabling DNS Pre-fetching but the option is gone, I'm not sure since when while it updates by itself.

My /etc/hosts looks like this:

#DEV
127.0.0.1       website1.local
127.0.0.1       website2.local
share|improve this question
    
- did you try with chromium? - are you using chrome extensions that might trigger this? –  Alex Barredo Jul 24 '11 at 17:16
    
@Adirael, does it happen with other file-types like JPG, etc. or only with PHP files? Try navigating directly to some non-PHP files on your server to check. –  Synetech Jul 24 '11 at 17:37
    
Happens too pointing to a JPG with all extensions disabled, same behavior as with PHP files: sometimes fast as lighting, but most of them slow as a turtle. –  Adirael Jul 24 '11 at 18:06

1 Answer 1

up vote 8 down vote accepted

thee matter is Lion handles .local TLD differently because it's reserved for some Multicast DNS features (used by Bonjour). The only way i found to solve this issue is using a different TLD for development hosts (ie: .dev). It works fine for me

share|improve this answer
    
Seems to be working, I changed to .dev and now they're fast. Weird thing is on Firefox they worked OK, maybe Firefox caches the DNS requests and Chrome is not doing it anymore. –  Adirael Jul 30 '11 at 23:19
    
This worked for me on Win7 as well, so it might not be limited to just Lion. –  Warren Benedetto Jul 9 '12 at 18:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.