Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Perhaps I need to load a driver to get Lion to recognize my WD 500 Password USB drive. However, I thought for sure I could load my thumb drives. But they don't appear anywhere on the desktop (that I can see) when I plug them in.

Where can I see a list of all drives in Lion?

share|improve this question
7  
Do you have Finder->Preferences->General->External Disks checked? and Finder->Preferences->Sidebar->External disks? –  Vervious Jul 24 '11 at 23:14
    
I do now. Thanks. But its definitely not the default. Where do these devices show up when these items are not checked off? –  Scott B Jul 25 '11 at 3:31
    
I don't think they do show up anywhere easily seen unless the prefs are checked but I'm not sure. –  Vervious Jul 25 '11 at 3:40

1 Answer 1

up vote 12 down vote accepted

There are several possible answers here.

In Finder, click on Finder at the top of the screen, then Preferences. Underneath Show these items on the desktop make sure External Disks is checked. Similarly, click on the Sidebar tab, and tick External disks there. Now close the Preferences window and check your Desktop and Finder sidebar.

If you still don't see anything, make sure Finder in selected, then click on Go, then Go to folder. In the window that's dropped down, type in /Volumes/ and hit Enter. You should now be in a Finder folder called Volumes that contains links to all of your connected drives and mounted disk images. Is your USB drive there?

If not, let's see if it's connected but not mounting. Click on Spotlight, and type in Disk Utility. It might pop up before you finish typing. When you see it, hit Enter and let it load.

In Disk Utility, you should have a window with a sidebar inside it. In the sidebar, you should see your internal hard drive and any external hard drives you have connected. Can you see your USB drive in there? If so, but it's greyed out, click on it and click the big blue Mount button. Hopefully the hard drive should start working, and then appear on your Desktop.

If it refuses to mount for some reason, or you don't see it there at all, then it's unfortunately likely that there's something a bit wrong going on, either with your connection or the drive's hardware. That's beyond the scope of this answer, but I'll keep my finger's crossed that it doesn't come to that.

share|improve this answer
    
+1, the finder settings are not checked by default. Thanks! –  Scott B Jul 25 '11 at 3:36
    
Go to folder /volumes/ worked! Why in the world is it so hard to find on OS X? It should just appear IMHO. –  Pete Alvin Jul 26 at 1:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.