Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My MacBook does not turn off when I put it in sleep mode, when it is plugged in. I put the laptop on "sleep" or close the lid, but the computer stays on and stays hot! My MacBook goes to sleep fine (turned off and had pulsating white light when on battery). If it is plugged in & I put it to sleep, the screen shuts off, but the computer stays on (solid white light)!

This has been happening ever since the upgrade to Lion! Is there any way to fix this?

It shuts down fine & it goes to sleep fine when on battery. It does not go to sleep when plugged in, that is the issue! I have already tried resetting SMC & PRAM, fixing permissions, and disabled startup applications!

My friends macbook pro goes to sleep fine with Lion! What is wrong! This did not happen in Snow Leopard!

share|improve this question
    
So it also doesn't shut down when you press the Shut down button and select an appropriate option? Can you check in Activity Monitor.app if there is any process running at higher CPU load that would prevent shutdown? –  slhck Jul 25 '11 at 11:28
    
It shuts down fine & it goes to sleep fine when on battery. It does not go to sleep when plugged in, that is the issue! I have already tried resetting SMC & PRAM, fixing permissions, and disabled startup applications! –  user46818 Jul 25 '11 at 16:42
    
See if system.log (Console) has anything notable in it relating to sleeping, –  Vervious Jul 25 '11 at 17:49

4 Answers 4

I found that after disabling "Internet Sharing" in "Sharing" in prefs pane, it worked fine. Tried it on and off several times. Works ;-)

share|improve this answer
  1. Go to Utilities in the Applications folder and open the Terminal app.
  2. Type "pmset -g" without the quotes and hit enter.
  3. If "sleep" has 0 next to it and the words "imposed by" ; The number next to the imposed by is the process ID. Write that number down.
  4. Type "ps -e" and hit enter. This will list all running processes.
  5. Find the process imposing on the sleep mode and take appropriate action.

In my case it was process id 19 which turned out in this instance to be a print server process. I went to "Print & Scan" in System Preferences and reset deleting all installed printers from there. . . Problem solved. I added the one printer that I needed and sleep still works. I don't yet understand quite how printing can get this way with the sleep mode.

share|improve this answer

You can also do pmset -g to find out which pids are blocking sleep

share|improve this answer

Same here. I resolved it by going to System Preferences, then Sharing, and disabling options there. After this closing the lid would cause my MacBook to sleep. This was the first time I saw the new sleeping led pattern :)

I was then able to restore the sharing settings, and it appears to sleep normally.

share|improve this answer
    
gotta find a way to disable it... –  Xster Sep 21 '11 at 21:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.