Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

On a Dell Xps 15 (L502X) if I connect an external Samsung 205bw with a miniDP → VGA adapter, I can't see the native 1680x1050 resolution as available, even if it's probed correctly by Xorg:

[  6557.310] (II) intel(0): EDID vendor "SAM", prod id 541
[  6557.310] (II) intel(0):     EDID quirk: Use +hsync +vsync for detailed timing.
[  6557.321] (II) intel(0): Using hsync ranges from config file
[  6557.321] (II) intel(0): Using vrefresh ranges from config file
[  6557.321] (II) intel(0): Printing DDC gathered Modelines:
[  6557.321] (II) intel(0): Modeline "1680x1050"x0.0  146.25  1680 1784 1960 2240  1050 1053 1059 1089 +hsync +vsync (65.3 kHz)

While xrandr gives:

DP1 connected 1280x1024+1920+0 (normal left inverted right x axis y axis) 433mm x 271mm
   1280x1024      75.0*    60.0  
   1280x960       60.0  
   1152x864       75.0  
   1024x768       75.1     70.1     60.0  
   832x624        74.6  
   800x600        72.2     75.0     60.3     56.2  
   640x480        72.8     75.0     66.7     60.0  
   720x400        70.1  

I tried adding the resolution to xrandr, but it fails. Windows 7 on the same laptop can get the resolution right, so I ruled out hardware problems.

share|improve this question
    
I don't like to accept incomplete or not very useful answers, should I just accept the less useless one? –  Metiu Jul 25 '11 at 14:37
    
I find it hard to believe that out of all the questions you asked, none are/were helpful and led to a positive conclusion. However if that is the case, then no only accept answers that were helpful. –  MaxMackie Jul 25 '11 at 14:38
    
Sorry maybe I misunderstood the meaning of "accepted": I thought I had to accept just the best answer... maybe I need to go back to the help pages. Thank you for pointing out. –  Metiu Jul 25 '11 at 14:52
    
Confirming the same problem with MiniDP -> DVI on the Dell XPS 15 (L502x). Have you been able to find an answer in the meantime? –  Beanow Jan 12 '12 at 10:06
1  
I asked xorg developers on irc. Basically, the chip in the converter is not able to reach the needed frequencies for high resolution monitors, so they need to use some dithering. There is a proposed patch, but it's not in the mainstream source tree. DVI is ok, though, so I'm using it. –  Metiu Jan 16 '12 at 10:56

3 Answers 3

up vote 2 down vote accepted

I solved!!! Update the kernel to the, in my case, 3.2.

http://www.howopensource.com/2011/08/how-to-install-linux-kernel-3-1-rc2-oneiric-in-ubuntu-11-04-10-10-and-10-04/

and enjoy!!!

share|improve this answer
    
I confirm that with the latest kernel the VGA cable works up to 1920x1080. –  Metiu Feb 27 '12 at 21:53

Today after installing the latest updates. This problem has now been resolved for me on my Dell XPS 15 (L502x) using a MiniDP -> DVI cable. My 1080p monitor is now able to go up to it's native resolution. I'm not able to determine from the release notes which of the updates I installed resolved the problem. But my guess is that it was one of the bumblebee updates.

I'm running Ubuntu 11.10 using the following ppa's for the source of this update:

ppa:bumblebee/stable https://launchpad.net/~bumblebee/+archive/stable

ppa: ubuntu-x-swat/x-updates https://launchpad.net/~ubuntu-x-swat/+archive/x-updates

Please verify this update worked for you as well.

share|improve this answer

I had a similar case. I was using a mini display port to VGA adapter, but could not change to the external screen resolution I wanted. When swapping to a mini display port to DVI adapter this went away, and Gnome automatically picked up the correct external display settings.

So before fiddling with your system config test it with alternative hardware.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.