Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Consider next situation:

  1. one phone line with DSL connection (Annex B),
  2. one Annex B DSL modem with one LAN port (Zyxel P660RT2)
  3. one Annex A DSL/modem+router (Huawei EchoLife HG520)
  4. one old laptop with only LAN port and Win XP SP3
  5. one laptop with wifi and LAN with Win7 onboard

We need to make internet available on both laptops

So i configured PPPoE on Zyxel, connected it via LAN with Huawei, and then connected Huawei via LAN with old laptop and via wifi with new one. I manually set all ip's in the network and set default gateways in laptop's LAN configs to zyxel's IP.

Internet connection appears to be working but it's very slow (but if i connect zyxel directly to any of laptops i get all 10mbps), neither if both laptops are connected nor with only one of them.

I've tried to disable DHCP on both laptops and everything i've managed to find in modem's menues but connection speed doesn't change.

share|improve this question
    
What is your total speed supposed to be? –  soandos Jul 25 '11 at 14:40
    
DHCP isn't something you want to be disabling unless you're using static addressing. Have you disabled the routing function of your huawei to act as a switch or is it functioning as a gateway/router? If so, is its default gateway set to the local address of your Zyxel? –  Daniel Ball Jul 25 '11 at 14:50
    
Well since there are only 4 nodes in the LAN i've decided to set up ips manually and turning DHCP off hoping that it would solve problem. Can't quite say if one could put hg520 in switch mode or smth - i'm not that qualified in net protocols at all. Right now huawei's default gateway and primary DNS are both set to ip of zyxel (as those of laptops), so like EVERYTHING i could imagine is set up manually, but for some reasons speed is very low (i had not enough patience to wait untill speedtest.org would finish loading and online audio is buffering all the time) –  idrozd Jul 25 '11 at 18:36
    
thx for attention btw ) –  idrozd Jul 25 '11 at 18:38

1 Answer 1

I am curious as to why you have a modem/router behind another modem/router. If for some reason you need to keep the devices in the same order then try disabling the routing functions of the Zyxel essentially turning it into a modem. Then set up the PPPoE on the EchoLife to allow it to act only as a router. I have seen routers set up behind routers give slow, intermittent, full, and no connections many times.

share|improve this answer
    
Well zyxel has only one LAN port but it's Annex B )) the thing is - i'm trying to have wifi network without buying new modem )) –  idrozd Jul 26 '11 at 4:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.