Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I had no problem installing the Play! framework on Windows but can't troubleshoot why it's not working on OS X.

I grabbed the latest version and unzipped it to a directory. I run the Unix executable file and get the Play terminal. At the end of the terminal it says:

[Process Completed]

I can't type in the terminal as well.

share|improve this question

migrated from stackoverflow.com Jul 25 '11 at 16:03

This question came from our site for professional and enthusiast programmers.

    
This isn't a programming, question. This should get moved pretty quickly, but in the future, try Super User for non-programming, computer-related questions :) – Cam Jackson Jul 25 '11 at 6:17
up vote 7 down vote accepted

You can not run the play executable from the desktop. You must run it from an open terminal window. Go to Applications -> Utilities and start Terminal.

Furthermore you need to add play to your PATH:

mkdir ~/bin
ln -s <path to your play home>/play ~/bin
echo "export PATH=~/bin:$PATH" >> ~/.bashrc
. ~/.bashrc

Now you can run

play new appname

from the Terminal window.

share|improve this answer
    
Hi Andre. I tried what you wrote above and the Play command from the terminal window is not recognized. – chopps Jul 25 '11 at 17:39
    
Ok..i got it to work. I used X11 and it worked. Not really sure what X11 is compared to the regular terminal though. – chopps Jul 25 '11 at 18:34

UPDATE 2015: The play command has been superseded by Typesafe Activator.

If you have homebrew installed then you can do 'brew install typesafe-activor' to install Typesafe Activator. This will allow you to use 'activator' commands instead of play commands.

It's also worth noting that most of the commands you would use are available directly from sbt. Personally, I would only use activator to create a blank project. From then on, I do day-to-day tasks from sbt. (E.g. 'sbt ~run' to run the play app in dev mode, with the ~ so it is reloaded every time a file changes.)


Old answer from 2012:

The easiest way is to use MacPorts or Brew. If you have brew installed, you can just run:

brew install play

Creating a bin folder, containing a symlink, which is on your path is also a good idea - as Andre suggested. It involves a few steps, but you will likely want to easily add more applications to your path in future.

share|improve this answer
    
does brew indicate what version of play is used? – crockpotveggies May 10 '13 at 6:30
    
Update: looks like they're only offering the latest version 2.1.1 as of this post – crockpotveggies May 10 '13 at 6:45
1  
It does not work this way anymore: Error: No available formula for play Play 2.3 replaces the play command with activator: brew install typesafe-activator You can read more about this change at: playframework.com/documentation/2.3.x/Migration23 playframework.com/documentation/2.3.x/Highlights23 – Richard Topchiy Nov 16 '15 at 14:51
    
Thanks Richard. I've edited the answer to reflect this. – Grogs Dec 11 '15 at 21:37

If you are used to Linux and its package managers checkout http://www.macports.org/ You could then simply install play (or loads of other stuff) from the terminal

share|improve this answer
    
Once you have MacPorts installed, the command to install Play Framework is: sudo port install play – AWhitford Nov 27 '11 at 9:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.