Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

So, I finally succumbed to iTunes 10 after it bugging me to upgrade over and over again! Now I can't import CDs properly, it gets to the end of the first track, then it still says it's importing, but the remaining time and rip speed are no longer displayed. At this point, I tell it to stop importing, to find that the first track was successfully converted to mp3 and is in my music folder, but hasn't been added to my iTunes library. I did this for the rest of the album, importing each track, then hitting stop when it had finished and moving onto the next track. After the first 3 tracks, I dragged them into my library and they appeared fine, yet I tried doing this for the rest of the album once the tracks had all been ripped, but they never appeared in the music library. The strange thing is, they are all present in the "Recently Added" playlist and can be played fine from there, but don't show up in the library at all. I was also able to add the tracks to my iPod without any problems, they just don't appear in my iTunes music library.

Has anyone else had this problem and managed to fix it? Getting seriously tempted to go back to iTunes 9 as this is just unusable.

Thanks

share|improve this question
    
I've just imported another CD and now it's working fine. Stranger still, the tracks that were refusing to play nicely before are now magically showing in the music library, no idea what caused this, I just hope it doesn't happen again, it's really annoying! –  TabbyCool Jul 25 '11 at 18:52
add comment

1 Answer

It might have just been a lag in iTunes. After you restarted the program, the CD tracks which you dragged to your library, must have appeared (as you say).

Note that iTunes is a bulky program which would take its time and doesn't like to be pushed around too much =).

share|improve this answer
    
I've been using iTunes for 6 years and have never had this happen until I updated to the latest version. Since then it's happened a few times and iTunes has literally been the only thing running. I restarted iTunes a couple of times whilst trying to import the first CD, but then the second CD worked fine straight after the first CD failed (no restart inbetween) so I definitely think it's more than just a lag in iTunes. I've been having other problems with this version too, like sometimes if I select an artist in the iTunes browser, it lists all of the albums in my library under that artist. –  TabbyCool Sep 27 '11 at 8:39
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.