Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

After plugging in a memory stick, the laptop can take up to 2 minutes to discover and show up in explorer. I have tried 3 different makes of stick so far, Transcend, Kingston & Corsair. All are USB 2.0 compliant. All work fine in various other boxes. All of them contain nothing but data (MS docs, pdfs, images & text files). No autoruns, clever encryption or utilities. All are eventually discovered and usable.

Laptop is an ASUS X71Q running Windows 7 32-bit Home Premium, 3GB of RAM. (Out of warranty)
Norton Internet Security is installed, however, with it temporarily disabled I still get the delay.

I am not asking about data transfer rates.
There is no problem with USB mice or keyboards.
This happens at any time, not just straight after booting.
There is no "installing device drivers" message.
I have removed or stopped all ASUS bloatware/utilities.
It happens on all USB ports.
USB drivers are from MS (recommended by ASUS) and have been removed/reinstalled.
It makes no difference if it is running on battery or adapter.
It also happens in safe mode.
Memory usage is sat at 1-1.25GB before I plug in the stick and doesn't change after.
Disk cache increases by 6MB when the stick is recognised and drops back down when it's removed.
None of the sticks are readyboost compliant.
Defrag of the HDD has made no difference.
There is no delay when using a Kubuntu LiveCD

share|improve this question
    
How about in safe mode? –  admintech Jul 26 '11 at 9:02
    
How much RAM does the PC have? How much RAM is in use when plugging in the memory stick? Is the PC paging when the memory stick is plugged in? –  Stacey Richards Jul 26 '11 at 11:44
    
@Stacey the question has been edited with answers –  Tog Jul 26 '11 at 17:36
    
@admintech ditto –  Tog Jul 26 '11 at 17:37
    
Out of curiosity, run a defrag C: /a. How fragmented is your primary disk? –  Breakthrough Jul 26 '11 at 17:42

4 Answers 4

Try to insert the device while looking at the Device Manager. If the discovery is that slow, you might be able to see the different phases of detection: USB device, vendor/product ID, USB Mass Storage Device, volume, drive letter assigned.

share|improve this answer
    
I'll check tonight –  Tog Jul 26 '11 at 13:28
    
Nothing happens in the device manager up to the point when it is discovered, then it refreshes the display and all is ready for use –  Tog Jul 26 '11 at 17:30
up vote 1 down vote accepted

Not an answer, really, I formatted and reinstalled Win 7. Reinstalled all the programs that were on the laptop and USB sticks are now recognised straight away.

share|improve this answer

Could "ReadyBoost" be automatically activated on those devices for some reason?

Check both your BIOS and devmgmt.msc and see if your USB controllers have any weird power management options enabled.

Try seeing if there's a chipset driver update for your system. Check the manufacturer's website. You might find out what your USB controller is and see if there's an firmware or driver update for it from the controller manufactuer's website (but likely the "USB Controller" on your system is part of the chipset and likely made by Intel...)

Also see if there's a BIOS update for your system.

If none of that helps, I'd say you have a motherboard hardware issue.

You might try booting a Linux live CD, opening a root terminal, and entering the following command:

tail -f /var/log/kern.log

Then insert the drive. Linux provides much more verbose error messages than Windows and it might lead to additional clues.

share|improve this answer
    
None of the sticks are readyboost compliant. There are no firmware/driver updates of any kind available. I hadn't thought of using a Live CD but that will have to wait until tomorrow as they're at work. There's no point in making any changes to the system settings until it starts to show the symptoms again but I will post back with results when they do. –  Tog Jul 26 '11 at 19:36
    
Kubuntu discovers the stick straight away and when I click on it in the file manager it is mounted and accessible almost immediately (just the usual delay as the DVD chunters) –  Tog Jul 27 '11 at 8:40

I used the device manager to delete the usb drivers while the drive was in the usb port. Removed the usb drive and reinserted it. this forced windows to reinstall the drivers. After that, I had no more problems with detection speed. Hope this helps others.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.