Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm quite a novice when it comes to Mac OS X (but I am an IT professional using Windows and Linux), but I have recently started using one.

The computer came with a 109-key japanese keyboard, but I want to use a 105-key english keyboard with it. Since this is the actual keyboard layout (not the key mapping), if this were Windows, I would go to the device manager, and change the keyboard driver to "105-key keyboard".

How do I do this in Mac OSX 10.6?

Edit: The actual scancodes for the 109-keyboard are different from those for the 105-keyboard, because of this, I need to change the keyboard driver, not the input source.

Edit2: I'm experiencing this exact problem: http://support.microsoft.com/kb/927824 I just need the equivalent solution for Mac OS X

share|improve this question
add comment

3 Answers

Actually, I found that by adding and using the Australian keyboard as another input (Language & Texts -> Input Sources, not through the kotoeri preferences) my similar issue was solved.

Setting to the kotoeri preference to use Spanish was almost perfect except typing > would launch the kotoeri word register.

Don't know why Australian works and not US, but I am happy for now I can use synergy and connect to my Japanese MacBook with a US keyboard attached to my synergy server.

share|improve this answer
add comment
up vote 1 down vote accepted

After more than a week, I found the answer to this issue. The details are explained in here:

http://msyk.net/macos/winkeyboard/#

Mostly, what you have to do is set the japanese kotoeri keyboard, and in the kotoeri preferences, set your language of choice for romaji input. I found that the english layout didn't work as I wanted, but the spanish one seemed to work perfectly.

Unfortunately, this is not available for the google japanese input.

share|improve this answer
    
Your link is dead, but I found the Kotoeri preferences from the menu bar. Unfortunately, I have the opposite problem, the layout is set to US, but I am using a Japanese keyboard - and (unbelievably) Japanese doesn't show in the options!! –  Noah Apr 11 '13 at 6:50
add comment

You can change your keyboard at System Preferences -> Languages and Text -> Input Sources.

share|improve this answer
    
As I mentioned in my post, this is not a keyboard mapping, but a keyboard layout problem. The same japanese input source works differently on a computer bought in Japan (preinstalled with a 109-key keyboard), than on a computer bought somewehre else (preinstalled with a 105-key keyboard). In Windows, you solve this not in the keyboard settings, but by changing the actual keyboard driver. I need to do the same in Mac OS X. As a different example, using the us-english input source, with the 109-key driver, the @ mark is shift-2, while with the 105-key driver, it's next to the P, with no shift. –  mhr Jul 27 '11 at 7:28
    
To put it another way, this might work with something like Spanish where the input method pretty much is the same as the mapping. Japanese, Korean, and Chinese have multiple levels of conversion. First, there is the actual key layout mapping (i.e. which keys are where), and /then/ there is a software layer that converts the input keys from the lower layer into JA. Selecting "Kotoeri" turns on the higher level layer to allow input of JA, but it says nothing about what kind of keyboard you are physically using. (For example, you can type JA on a US-EN or DE keyboard, or EN on a JA keyboard). –  Noah Apr 11 '13 at 6:54
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.