Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've created a custom form in Outlook 2007 and made it the default form for posting to custom Calendar folder. My end goal is to set the default reminder time. To that end, I've set the "Reminder" property to "No" and "Reminder Beforehand" to 0 and published the form.

Form Designer

When I try to create a new appointment using this form, the interface simply defaults back to the system-level default reminder time of 15 minutes.

NoReminder2 Appointment Form

If I reopen the custom form in Form Designer, the properties are reset back to "Yes" and "15". Any ideas?

I'm not looking for a solution such as Reminder Manager.

share|improve this question
Can you post a screenshot or two? This functionality is not widely-used, so hard to picture. – KCotreau Jul 26 '11 at 18:18
Absolutely. I added a few that should help clarify. – oldSchool Jul 26 '11 at 18:28
Thanks, I will have to try re-creating this later. I will post back, evne if I can't figure it out. – KCotreau Jul 26 '11 at 19:18

I had the same problem. It appears to be caused by the "default reminder" Calendar option (in Tools|Options).

I did not want to disable that option, as I want normal appointments to have normal reminders. Thus, I opened the Design Form window, chose View Code and entered:

Function Item_Open()
  ReminderSet = False
End Function

This sets the reminder to 'None' every time the appointment is opened for editing. Not perfect, because it means that if you do want a reminder and set it, this'll be removed the next time you open it for editing. But it's good enough for my purposes.

Unfortunately, I could not find some On_Create type of event to make this work smoother.

ps. Do you know a way to make custom forms more accessible? (i.e. by a shortcut or by adding it to the New.. dropdown)

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .