Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to set up an FTP server on a ubuntu virtual server (over ssh). I'm very new to Linux and servers.

I have installed vsftpd, and had no problems setting it up, but now I'm clueless. How I download something from the server now?

Furthermore, although the page didn't tell me that I had to manually start it, typing vsftpd into bash gives me 500 OOPS: could not bind listening IPv4 socket. I'm not even really sure what the problem is.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Ok what would help is how you installed it, if you haven't installed it through apt then I would recommend doing so.

To solve your 500 error edit your vsftpd.conf file located at /etc/vsftpd.conf

add the following line at the end of it:

pam_service_name=vsftpd

To access the server you will need to know the local ip address assuming you are using a home server.

To do this type ifconfig and find the ipv4 address of your active network interface; 192.168.0.?

Then simply go to another system on the network and enter your ip address into an FTP client with user credentials and it should work if you have configured everything else correctly.

share|improve this answer
    
I did use apt to install it, using these instructions help.ubuntu.com/10.10/serverguide/C/ftp-server.html I now added that line to the end of the config file, and restarted it with sudo restart vsftpd. That worked fine, but writing vsftpd still gives me the same error. Thanks for the info on the FTP client though :) –  Hannesh Jul 26 '11 at 20:06
    
I fixed it by changing the listen_port. Something else must be using the default one. –  Hannesh Jul 27 '11 at 7:53
    
This was also going to be my next suggestion, having a first look at the error shows that it was not bindable to the port, therefore in use. –  Sandeep Bansal Jul 28 '11 at 0:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.