Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

In Snow Leopard, I had the window switch animation disabled when I quick-key between spaces. Now that it's Mission Control in Lion, there's this long animation during which all my desktop icons disappear and I can't use anything. I'd really like to disable this, but the old fix doesn't appear to work.

Does anyone know how to disable this needless animation in OS X Lion?

share|improve this question
1  
If you use the 3-finger swipe on the trackpad, the animation can go much faster. But I'm usually using an external keyboard & mouse, and I agree that the animation for the keyboard shortcut is painfully slow. –  John Douthat Jul 27 '11 at 19:20
    
Unfortunately I mostly use my mac in clamshell mode with an external keyboard, monitor and mouse. –  Daniel Lew Jul 27 '11 at 20:26
4  
Related: apple.stackexchange.com/questions/17929/… –  Mathias Bynens Jul 30 '11 at 18:40
    
I have the same problem and question. Found a solution? –  Matt Oct 8 '11 at 12:58

4 Answers 4

Does this article relate to your problem ?

It advocates this command :

defaults write NSGlobalDomain NSAutomaticWindowAnimationsEnabled -bool NO

For desktop switching, I quote from How can I disable animation when switching desktops in Lion? :

I've just noticed that doing Control+Number is noticeably faster than Control+Arrow. It's still animated but it does complete the animation in about half the time.

Sadly, Mission Control hasn't yet been modified (or the secret preferences to tweak it haven't yet been baked in or discovered.)

You really have no choice other than staying on 10.6 or seeking an alternate window manager like hyperspaces.

share|improve this answer
    
That pertains to the individual window animation, not desktop switching (aka virtual desktops). –  Daniel Lew Jul 31 '11 at 13:44
    
Added some more stuff. –  harrymc Jul 31 '11 at 16:18
2  
You can add all you want, but I won't accept it unless you answer the question. –  Daniel Lew Jul 31 '11 at 21:02
4  
Some questions have only negative answers. Your question may have been posted too early, and the full answer is not yet known. At this time, I can't do better than the above, but you have of course the right to wait for a better answer or accept none. –  harrymc Aug 1 '11 at 5:40

Change the delay when dragging windows or applications within Spaces.

Launch the Terminal and enter the following at the command line:

defaults write com.apple.dock workspaces-edge-delay -float 0.1

The number on the end represents the wait time - the default is set to 0.75 (or 3/4 of a second), so 0.5 is half a second, 0.1 is a tenth of a second, and so on. If you use the above command and 0.1 you’ll get a near instant switching of spaces.

If you want to revert to the default setting, just specify it as so:

defaults write com.apple.dock workspaces-edge-delay -float 0.75
share|improve this answer
    
I'll give this a vote because it is helpful, but it's still not a solution proper yet. –  Daniel Lew Sep 8 '11 at 16:41

You can disable the animation that shows up when you launch mission control with this

defaults write com.apple.dock expose-animation-duration -int 0; killall Dock

and undo with

defaults delete com.apple.dock expose-animation-duration; killall Dock

If you'd like to keep the animation, but speed it up, you can do this instead

defaults write com.apple.dock expose-animation-duration -float 0.1; killall Dock

I don't know how to disable the annoying sliding animation when moving between spaces without using mission control, though--as was mentioned above, using ctrl+1, ctrl+2, ... does make that animation a lot faster.

share|improve this answer
    
Thanks! Works in Mountain Lion as well. –  laktak Sep 12 '12 at 6:19

You can disable the animations with TotalSpaces (born ReSpaceApp). Just uncheck the Use transitions checkbox in TotalSpaces preferences.

share|improve this answer
1  
awesome! this worked. –  rizumu Mar 27 '12 at 20:30
    
For me as well. After almost a year, we finally have a solution! –  Trevor Powell Apr 16 '12 at 7:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.