Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've looked in the usual places, page settings, and printer settings, but unless I go to Page Layout and select A4 for each new sheet, it opens as letter.

I've found a few workarounds, but they all require more steps than I can rely on my co-workers to remember everyday.

Is there a default setting to change that I am just missing?

share|improve this question
1  
You should open the Properties of your default printer, and set paper size as A4. –  Mehper C. Palavuzlar Jul 27 '11 at 8:51
2  
Paper size of the default printer is set to A4 already. When i print, the printer give a "Paper Mismatch Error" each time I print, unless the document also matches the A4 size in it's properties. Since i can't find a place to change the default settings, we have to remember to change it each time we start a new document. –  zenbike Jul 27 '11 at 9:03
    
Just to make sure: This problem is about new documents? Each time you say "New" in Excel, the newly created workbook has Letter as page format? –  TeX HeX Jul 27 '11 at 10:56
    
As page size for printing, yes. –  zenbike Jul 27 '11 at 11:01
add comment

4 Answers

up vote 2 down vote accepted

As this is about new workbooks, the easiest way would be to create a default template that is automatically used by Excel.

Create a new workbook and set all settings you want to have, especially the paper size. For testing purposes I would also suggest that you add some text to a cell in the first sheet so you can easily see when Excel is using the file.

Save this as “Excel Template (*.xltx)” and copy it over to the XLStart of your Office Installation (e.g. C:\Program Files (x86)\Microsoft Office\Office12\XLSTART). The file name is a little bit tricky since Excel will use a localized filename.

Means, if you are using an English Excel, the file should be named Book.xltx. Since you want to use DIN A4 paper, I’m assuming that you are using a German Excel – in this case the filename has to be Mappe.xltx.

Exit Excel and restart it. If the new workbook shows the test text you have entered, it has successfully picked up the file.

If it does not show up, it can be because a user default template exists (Excel favors user templates over system templates). The location of the user default template is C:\Users\\AppData\Roaming\Microsoft\Excel\XLSTART.

More information on this topic (for example, a template when adding sheets to an existing workbook) can be found here, here or here.

share|improve this answer
    
I appreciate the answer. Is there no setting for this? Or maybe an explanation why something that seems so basic to me, doesn't exist? –  zenbike Jul 27 '11 at 13:47
    
To be honest, this is the solution I know that works since we are using it. Sorry if it is complicated. And I really don't know why there is no easy option for this. But if the solution of KCotreau works for you, you have an easy option for it :) –  TeX HeX Jul 27 '11 at 14:11
    
@TeX HeX I figured it out, and it was my mistake. Your answer is 100% correct also. I edited my answer some to take out that portion. Sorry about that...human. +1 to you. –  KCotreau Jul 27 '11 at 19:06
    
@KCotreau thanks for the update and no harm done. I was just curious why the heck this worked on my side but not for you. Thanks for the +1! –  TeX HeX Jul 27 '11 at 19:25
    
Thanks, guys. I was hoping for something less complex for the user, but this works. i'm awarding the answer to @Tex Hex, because he was first, although both work. –  zenbike Aug 1 '11 at 9:42
add comment

You may find that this issue also shows up in Notepad and Wordpad, but not another Office application like Word. If so try this.

Close your applications. Delete your default printer, then re-add this printer.

share|improve this answer
add comment

I was seeing the same issue and the following steps worked for me in Excel 2007. It may work for Excel 2010 but someone will need to verify this.

  1. Start up Excel. You should have an empty workbook displayed.
  2. Click the "Office" button (top left) then the menu item "Print" and the sub-menu item "Print". The print dialog window will display.
  3. Make note of the printer name showing in the dialog box. Mine was listed as "Microsoft XPS Document Writer".
  4. Exit from Excel.
  5. Via the Windows control panel/printers, select the printer identified in step #3. Pick the "Printing Preferences" of the right-mouse click menu.
  6. Go find where the default paper size is specified. For my printer, it was via an "Advanced" command button. Set the default paper size to A4. Click "Ok" and close any printr dialog windows.
  7. This step may not be required. Right-mouse click the printer again and pick "Properties". Select the "Printing Preferences ..." command button. Repeat step #6.
  8. Fire up Excel again. Check the menu item "Page Layout/Size" to see if you now have an A4 page size by default.

Your mileage may vary.

Regards,

David

share|improve this answer
add comment

For Excel, you can use TeX HeX's answer or this also works:

  1. Open a blank workbook, and go to Page layout>Size and set it to A4.
  2. Then just save it to C:\Program Files (x86)\Microsoft Office\Office12\XLSTART. You do not even need to change the extension, and mine was named the default "Book1.xlsx".
  3. Test by re-opening Excel. It worked perfectly for me.

In Microsoft Word, go to Page Layout>Size>More Paper Sizes (at the bottom of the menu). Set your size, and click Set as default.

enter image description here

share|improve this answer
    
Could you please clarify what was not working for you? I just verified the method you described and what happens is that Excel actually opens the Book1.xslx from the XLSTART folder in Read-Only mode (because a normal user does not have any write access to to it). When using the file as XLTX template, only the correct localized name will actually change the defaults in Excel - Mappe for German, Book for English installations. I also confirmed that this works the same for OFFICE12\XLSTART or OFFICE14\XLSTART. –  TeX HeX Jul 27 '11 at 18:12
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.