Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am unable to get Notepad++'s NppFTP to connect as localhost to my Windows XP. I want to "upload" the current file from a "src" directory to the local /xampp/htdocs directory during development.

Ironically, I am able to connect remotely to my eventual deployment server.

Settings are:

Hostname: localhost
Connection type: FTP
Port: 21
Initial remote directory: \xampp\htdocs\junk
share|improve this question

migrated from programmers.stackexchange.com Jul 27 '11 at 18:09

This question came from our site for professional programmers interested in conceptual questions about software development.

    
Have you tried using 127.0.0.1 instead of localhost? –  Fopedush Jul 27 '11 at 19:30

1 Answer 1

If you're running on Windows, make sure you're running your XAMPP control (XAMPP UI) as admin. Then, you have yo check the SVC checkbox before FileZilla, then click Start. A pop-up will prompt – click Yes to install it as a service.

After that, click Admin then click Yes. Set your password then you're good to go.

In you're using Notepad++, the settings are the same with the one you posted above.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.