Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Before Linux Kernel 3.0 (2.6.39) I can run the following command:

# ifconfig wlan0 up

Now I can't. I got an error saying that this device was not found. I've tried to unplug my usb dongle, plug and check how it is registered but i don't get any useful output.

What should I do when dmesg dont help? How could I identify how my device was registered?

Thank you.

share|improve this question
I can find my device through lsusb. My device is: Bus 001 Device 002: ID 0cf3:1002 Atheros Communications, Inc. TP-Link TL-WN821N v2 [Atheros AR9001U-(2)NG] It used to work with ar9170usb but now, with 3.0, it was replaced by carl9170. When I plug my wireless usb dongle, carl9170 appears in lsmod but dmesg doesn't show how it's identified. Thanks. – user92041 Jul 28 '11 at 14:15

You should check that your new kernel has the required modules built for the device in question (helps to know the chipset - atheros, prismI/II, marvell, etc..)

  1. cd into your Linux source directory
  2. Execute: make menuconfig
  3. Traverse the network devices section and look for your device's module (and enable). You can get help on each selection from the ncurses interface you see, and usually you see the name of the module that the functionality is provided as.
  4. make modules modules_install ; depmod -a
  5. modprobe modname <- get this information from step 3.

Apologies if you've already tried the above - not sure how things have changed in 3.x, but it sounds like you've simply not built in the support for your device.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .